This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 533649 - virt-manager trying to set ownership of nfs mounted iso?
virt-manager trying to set ownership of nfs mounted iso?
Status: CLOSED DUPLICATE of bug 517304
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-08 00:51 EST by Jens Petersen
Modified: 2009-11-08 02:28 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-08 02:28:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2009-11-08 00:51:09 EST
Description of problem:
I can't install iso's mounted locally over nfs

Version-Release number of selected component (if applicable):
virt-manager-0.8.0-7.fc12

How reproducible:
every time

Steps to Reproduce:
1. try to install iso mounted on nfs in v-m
  
Actual results:
Error starting domain: internal error unable to start guest: libvir: QEMU error : cannot set ownership on /mnt/iso/fedora-live.iso: Operation not permitted

v

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 571, in run_domain
    vm.startup()
  File "/usr/share/virt-manager/virtManager/domain.py", line 664, in startup
    self.vm.create()
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 293, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: internal error unable to start guest: libvir: QEMU error : cannot set ownership on /mnt/iso/fedora-live.iso: Operation not permitted


Expected results:
no backtrace and no need to change ownership.
Comment 1 Yanko Kaneti 2009-11-08 02:28:36 EST

*** This bug has been marked as a duplicate of bug 517304 ***

Note You need to log in before you can comment on or make changes to this bug.