Bug 53369 - --noscripts doesn't work
--noscripts doesn't work
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: rpm (Show other bugs)
roswell
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-07 11:49 EDT by Brian Harvell
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-07 11:49:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Harvell 2001-09-07 11:49:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010816

Description of problem:
when I specify --noscripts it still tries to run scripts
boondoggle[root][11:43][web-inf/bcs/scripts]# rpm -vv -e prngd --nodeps --nosc$
D:     erase: prngd-0.9.23-3 has 17 files, test = 0
D:     erase: running %preun script(s) (if any)
+ [ 0 = 0 ]
+ /etc/init.d/prngd stop
error: execution of %preun scriptlet from prngd-0.9.23-3 failed, exit status 1



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpm -e <package> --noscripts
2.
3.
	

Additional info:
Comment 1 Jeff Johnson 2001-09-07 11:54:35 EDT
What version of rpm (i.e. rpm -q rpm)?

If around rpm-4.0.3-0.60, upgrade to latest
version from Raw Hide (rpm-4.0.3-1.03 is very latest).

If problem persists in latest Raw Hide rpm package,
please reopen this bug and I'll figger what's broke.

Note You need to log in before you can comment on or make changes to this bug.