Bug 53376 - Support Request: chroot'ed ftpusers by default
Summary: Support Request: chroot'ed ftpusers by default
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: wu-ftpd   
(Show other bugs)
Version: roswell
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-07 17:28 UTC by Chris Kloiber
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-09 20:40:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Kloiber 2001-09-07 17:28:55 UTC
Description of Problem:

Probaby the number two question we get in support about ftp is how to
restrict users to their home (and perhaps web) directories. Can we make
that the default behavior for wu? (just add the group to ftpaccess and it
works)

Comment 1 Bernhard Rosenkraenzer 2001-09-09 20:40:31 UTC
The problem is that for this to work properly, every user needs a bunch of 
binaries in ~/bin.
Now that the internal ls is used by default, it's not as bad as it used to be, 
but it still breaks stuff like on-the-fly tarring/compression of directories.

I don't think many people use this feature though, I'll probably change it for 
8.0.


Comment 2 Bernhard Rosenkraenzer 2001-12-13 13:47:48 UTC
Changed in 2.6.2-1



Note You need to log in before you can comment on or make changes to this bug.