Bug 53384 - XFree86 4.1.0-0.9.13 fails on monitor probe
XFree86 4.1.0-0.9.13 fails on monitor probe
Status: CLOSED WORKSFORME
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
roswell
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-07 14:26 EDT by GeoffLeach
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-22 05:29:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description GeoffLeach 2001-09-07 14:26:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010803

Description of problem:
With /etc/X linked to XFree86 (4.1.0) these stanzas in XF86Config

Section "Device"
        Identifier      "Matrox Millennium"
        Driver          "mga"
        VendorName      "Matrox"
        BoardName       "Millennium"
        VideoRam        8192
EndSection

Section "Screen"
        Identifier      "ViewSonic"
        Device          "Matrox Millennium"
        Monitor         "ViewSonic P815"
        DefaultDepth    16

        Subsection "Display"
            Depth       8
            Modes       "1280x1024" "1024x768" "800x600" "640x480"
        EndSubsection

        Subsection "Display"
            Depth      16
            Modes      "1600x1200" "1280x1024" "1024x768" "800x600"
        EndSubsection

        Subsection "Display"
            Depth      24
            Modes      "1600x1200" "1280x1024" "1024x768"  "800x600"
        EndSubsection

EndSection

Result in this at startup (using startx in Roswell)

(II) MGA(0): DDC Monitor info: (nil)
(II) MGA(0): end of DDC Monitor info

Running the _same_ XF86Config with XFree86 4.1.0 downloaded in binary for
6.1 from xfree86.org gives this.

(II) MGA(0): I2C bus "DDC" initialized.
(II) MGA(0): I2C device "DDC:ddc2" registered.
(II) MGA(0): I2C device "DDC:ddc2" removed.
(II) MGA(0): I2C Monitor info: (nil)
(II) MGA(0): end of I2C Monitor info
(II) MGA(0): I2C device "DDC:ddc2" registered.(II) MGA(0): EDID Version: 1.0
(II) MGA(0): Analog Display Input,  Input Voltage Level: 0.700/0.300 V
(II) MGA(0): Sync:  Separate  Composite  SyncOnGreenSerration on. V.Sync
Pulse req. if CompSync or SyncOnGreen
(II) MGA(0): Max H-Image Size [cm]: horiz.: 40  vert.: 30
(II) MGA(0): Gamma: 2.54
(II) MGA(0): DPMS capabilities: StandBy Suspend Off; RGB/Color Display
(II) MGA(0): redX: 0.635 redY: 0.333   greenX: 0.280 greenY: 0.595
(II) MGA(0): blueX: 0.152 blueY: 0.063   whiteX: 0.283 whiteY: 0.298
(II) MGA(0): Supported VESA Video Modes:
(II) MGA(0): 640x480@60Hz
(II) MGA(0): 640x480@75Hz
(II) MGA(0): 1024x768@75Hz
(II) MGA(0): 1280x1024@75Hz
(II) MGA(0): 1152x870@75Hz
(II) MGA(0): Manufacturer's mask: 0
(II) MGA(0): Supported Future Video Modes:
(II) MGA(0): #0: hsize: 1600  vsize 1200  refresh: 85  vid: 22953
(II) MGA(0): #1: hsize: 1600  vsize 1200  refresh: 75  vid: 20393
(II) MGA(0): #2: hsize: 1280  vsize 1024  refresh: 85  vid: 39297
(II) MGA(0): #3: hsize: 1280  vsize 1024  refresh: 75  vid: 36737
(II) MGA(0): #4: hsize: 1152  vsize 864  refresh: 75  vid: 20337
(II) MGA(0): #5: hsize: 1024  vsize 768  refresh: 75  vid: 20321
(II) MGA(0): #6: hsize: 640  vsize 480  refresh: 75  vid: 20273
(II) MGA(0): #7: hsize: 1024  vsize 768  refresh: 60  vid: 16481
(II) MGA(0): Supported additional Video Mode:
(II) MGA(0): clock: 229.5 MHz   Image Size:  380 x 285 mm
(II) MGA(0): h_active: 1600  h_sync: 1664  h_sync_end 1856 h_blank_end 2160
h_border: 0
... and so on.

Anaconda didn't have any luck with the configuration either, even though
the moditor is listed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run startx
2.observe that the resolution is not right
3.check the output of startx
	

Actual Results:  as described above

Expected Results:  1600x1200 resolution

Additional info:
Comment 1 GeoffLeach 2001-09-10 11:07:17 EDT
Problem unchnaged after upgrade to version 4.1.0 release 1.0
Comment 2 Mike A. Harris 2001-09-22 05:28:58 EDT
Please attach full X server log and config file via the link
below.
Comment 3 GeoffLeach 2001-09-23 12:19:37 EDT
The console output from the server begins like this

his is a pre-release version of XFree86, and is not supported in any
way.  Bugs may be reported to XFree86@XFree86.Org and patches submitted
to fixes@XFree86.Org.  Before reporting bugs in pre-release versions,
please check the latest version in the XFree86 CVS repository
(http://www.XFree86.Org/cvs)

XFree86 Version 4.1.0.1 (Red Hat Linux release: 4.1.0-0.9.13) / X Window System
(protocol Version 11, revision 0, vendor release 6510)
Release Date: xx August 2001
        If the server is older than 6-12 months, or if your card is
        newer than the above date, look for a newer version before
        reporting problems.  (See http://www.XFree86.Org/FAQ)
Build Operating System: Linux 2.4.7-0.13.1smp i686 [ELF] 
Build Host: stripples.devel.redhat.com

So this establishes that /etc/X11/X was linked to XFree86, yes?
So I ran Xconfigurator.  It produced an XF86Config that worked (gave desired
resolution) and was different than the one I was using.  On checking, I 
discovered that /etc/X11/X was linked to XF86_SVGA.  I re-linked to XFree86,
and my XF86Config now works.

SoI'm happy, but I'm sure puzzled.  Was some entity fiddling with /etc/X11/X?
Comment 4 Mike A. Harris 2001-09-23 13:15:20 EDT
In Red Hat Linux you do not ever have to symlink the X server, nor
should you ever do so.  Xconfigurator handles the symlinks that
are needed on its own, and ensures that the X server is properly
getting started via Xwrapper.  Overriding this will cause problems,
various breakage and unexpected behaviour, and result in a setup
which is not supported by Red Hat.

As long as you do a fresh install of X, and use Xconfigurator for
configuration, the symlinks will remain sane.  For advanced configuration
look at the Xconfigurator manpage as well.  There are many features
on both the commandline, and in the interactive mode, of which some
are not immediately obvious.

Hope this helps.

Note You need to log in before you can comment on or make changes to this bug.