Bug 53387 - redhat-config-network crashes if hostname set to default
redhat-config-network crashes if hostname set to default
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-network (Show other bugs)
roswell
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-07 14:44 EDT by GeoffLeach
Modified: 2008-05-01 11:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-12 12:01:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description GeoffLeach 2001-09-07 14:44:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010803

Description of problem:
On a system where network configuration has not been done and so
hostname is "localhost" and where there is no network card, although
a
 dial-up connection to the internet was active at the tim
e, executing (as root) redhat-config-network resulted in the following dump.

    hardwarelist = getHardwareList()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 259, in getHardwareList
    HWList.load()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 118, in load
    wvdial = ConfSMB('/etc/wvdial.conf')
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/ConfSMB.py",
line 86, in __init__
    merge=1, create_if_missing=1)
  File "/usr/share/redhat-config-network/netconfpkg/Conf.py", line 180, in
__init__
    self.read()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/ConfSMB.py",
line 91, in read
    self.initvars()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/ConfSMB.py",
line 108, in initvars
    vars = self.next_entry()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/ConfSMB.py",
line 137, in next_entry
    vars = self.get_entry()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/ConfSMB.py",
line 123, in get_entry
    vars[1] = joinfields(vars[1:len(vars)], '=')               
IndexError: list assignment index out of range

Results are similar with up2date, rhn_register, etc.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.execute tool without network config
2.
3.
	

Actual Results:  As described

Expected Results:  A popup with error message saying what was expected and
what was found instead/

Additional info:
Comment 1 Trond Eivind Glomsrxd 2001-09-07 15:28:01 EDT
Can you try the 0.9-1 version at http://people.redhat.com/teg/neat/ ?
Comment 2 GeoffLeach 2001-09-08 15:55:18 EDT
Did that.  No joy.  BTW, this is _with_ the hostname set correctly -- or well
enough, at least, without network config!

    self.loadHardware()
  File "/usr/sbin/neat", line 216, in loadHardware
    hardwarelist = getHardwareList()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 260, in getHardwareList
    HWList.load()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 118, in load
    wvdial = ConfSMB('/etc/wvdial.conf')
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/ConfSMB.py", line
86, in __init__
    merge=1, create_if_missing=1)
  File "/usr/share/redhat-config-network/netconfpkg/Conf.py", line 180, in __init__
    self.read()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/ConfSMB.py", line
91, in read
    self.initvars()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/ConfSMB.py", line
108, in initvars
    vars = self.next_entry()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/ConfSMB.py", line
137, in next_entry
    vars = self.get_entry()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/ConfSMB.py", line
123, in get_entry
    vars[1] = joinfields(vars[1:len(vars)], '=')               
IndexError: list assignment index out of range
Comment 3 Ngo Than 2001-09-09 06:51:24 EDT
i cannot reproduce it, Could you please send me this file /etc/wvdial.conf. thanks
Comment 4 Ngo Than 2001-09-09 06:59:14 EDT
ok, i'am sure that you have a wrong /etc/wvdial.conf, please remove this file
and try to start redhat-config-network again. It should work

You should never edit /etc/wvdial.conf, if you don't know the syntax of it!
Comment 5 GeoffLeach 2001-09-10 11:11:31 EDT
Removing my version of the file (see below) resolved the problem.  However, as
You this file works fine on both 6.1 and on the beta, I must say that You should
[Dialer Defaults]
Modem = /dev/ttyS0
Baud = 115200
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 S11=55 +FCLASS=0
Auto Reconnect
#New Pppd

[Dialer slb]
Phone = 1-877-555-5554
Username = GLeach
Password = xxxxxxx

[Dialer slb2]
Phone = 1-408-555-5555
Username = GLeach
Password = xxxxxxx

[Dialer cd]
# This is a direct line
#Phone = 555-5555
Phone = 555-5555
Username = Pgeoff
Password = xxxxxxxx
never _parse_ /etc/wvdial.conf, if you don't know the syntax of it!




Comment 6 Ngo Than 2001-09-20 17:18:08 EDT
don't break if /etc/wvdial.conf is not sane.

Note You need to log in before you can comment on or make changes to this bug.