Bug 53388 - missing directory $QTDIR/tools/designer/templates
missing directory $QTDIR/tools/designer/templates
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: qt (Show other bugs)
7.1
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-07 14:53 EDT by Dimitri Papadopoulos
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-07 14:53:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dimitri Papadopoulos 2001-09-07 14:53:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12smp i686)

Description of problem:
The Qt Designer needs directory $QTDIR/tools/designer/templates otherwise
it will try to load template files from the current directory. I'll have to
agree that the relevant code in tools/designer/designer/newformimpl.cpp is
ugly:

static QString templatePath( const QString &t )
{
    if ( QFileInfo( "../templates" ).exists() )
	return "../templates";
    QString qtdir = getenv( "QTDIR" );
    if ( QFileInfo( qtdir + "/tools/designer/templates" ).exists() )
	return qtdir + "/tools/designer/templates";
    return t;
}

Trolltech will take care of this, maybe by deleting this curious function,
but $QTDIR/tools/designer/templates seems to be needed by the Qt Designer
for now.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Enter a directory that contains a few files.
2. Run the Qt Designer from this directory.
3. Click on the New toobutton.
4. The files of this directory appear as templates in the dialog.


Actual Results:  The files of this directory appear as templates in the
"New Form" dialog.

Expected Results:  Only the files in $QTDIR/tools/designer/templates should
appear.


Additional info:

I suggest adding a $QTDIR/tools/designer/templates in the current version.
Comment 1 Bernhard Rosenkraenzer 2001-09-09 16:37:33 EDT
Unfortunately this was reported slightly too late to make it into the next 
release. It will be addressed for the release after that.


Note You need to log in before you can comment on or make changes to this bug.