Bug 533893 - nfs service needs a restart before it works.
nfs service needs a restart before it works.
Status: CLOSED DUPLICATE of bug 532270
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-09 11:45 EST by Dave Jones
Modified: 2015-01-04 17:31 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-12 10:27:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2009-11-09 11:45:03 EST
when I try to mount nfs from my laptop, I get ...

mount.nfs: mount to NFS server 'gelk:/mnt/data' failed: RPC Error: Program not registered

if I log into the server and service nfs restart, I see ..

Shutting down NFS mountd:                                  [FAILED]
Shutting down NFS daemon:                                  [FAILED]
Shutting down NFS quotas:                                  [  OK  ]
Shutting down NFS services:                                [  OK  ]
Starting NFS services:                                     [  OK  ]
Starting NFS quotas:                                       [  OK  ]
Starting NFS daemon:                                       [  OK  ]
Starting NFS mountd:                                       [  OK  ]

and then the mount works fine.

Something isn't starting up correctly. I don't see anything interesting in the logs.
Comment 1 Steve Dickson 2009-11-09 12:26:32 EST
This is because Network Manager starts the network asynchronously
which means there is a good possibly an newtwork interface is not
configured when rpc.nfsd start. BZ 531425 has a more detailed
explication... 

I wonder if this should be a blocker bug...
Comment 2 Dave Jones 2009-11-10 12:27:15 EST
Definitely a regression since f11.  It worked fine before I yum update'd the server.
Comment 3 Steve Dickson 2009-11-12 10:27:51 EST

*** This bug has been marked as a duplicate of bug 532270 ***

Note You need to log in before you can comment on or make changes to this bug.