Bug 533897 - /dev/shm has wrong permissions on startup
/dev/shm has wrong permissions on startup
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
12
All Linux
low Severity urgent
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-09 11:54 EST by Andy Lutomirski
Modified: 2010-05-01 14:34 EDT (History)
4 users (show)

See Also:
Fixed In Version: 004-4.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-27 19:53:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Verbose output of dracut -f (12.22 KB, text/plain)
2010-04-29 13:16 EDT, Resa Drijsen
no flags Details

  None (edit)
Description Andy Lutomirski 2009-11-09 11:54:08 EST
I upgraded my F11 system to F12 (whatever's in the yum repos right now), and, on startup, /dev/shm has 0755 permissions.  This breaks all kinds of things.

This looks like a bug at least in dracut, and maybe in /etc/fstab and/or initscripts.  fstab has a line:

tmpfs                   /dev/shm                tmpfs   defaults        0 0


And dracut has (in 99base/init):

mount -t tmpfs /dev/shm /dev/shm >/dev/null 2>&1


In any case, this bug should be fixed before release.
Comment 1 Bill Nottingham 2009-11-09 12:27:05 EST
Pushing to dracut for the moment.
Comment 2 Bill Nottingham 2009-11-09 12:33:11 EST
I'm not seeing this here; it's 1777 for me.
Comment 3 Bill Nottingham 2009-11-09 12:34:32 EST
Out of curiousity, are you using RAID?
Comment 4 Andy Lutomirski 2009-11-10 11:08:42 EST
I'm using LVM over dm-crypt.
Comment 5 Fedora Update System 2009-11-27 10:12:45 EST
dracut-003-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/dracut-003-1.fc12
Comment 6 Fedora Update System 2009-11-30 23:40:08 EST
dracut-003-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dracut'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12432
Comment 7 Andy Lutomirski 2009-12-01 12:48:24 EST
dracut-003-1.fc12 fixes this bug for me.  Thanks!
Comment 8 Fedora Update System 2010-01-26 05:48:09 EST
dracut-004-4.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/dracut-004-4.fc12
Comment 9 Fedora Update System 2010-01-26 20:05:35 EST
dracut-004-4.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dracut'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1088
Comment 10 Fedora Update System 2010-01-27 19:50:53 EST
dracut-004-4.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Resa Drijsen 2010-04-29 10:08:47 EDT
I have recently installed Fedora 12 in a separate partition to dual boot it with Ubuntu. After installation of Chromium I was confronted with the following error:

[1801:1809:1835452427:FATAL:base/shared_memory_posix.cc(193)] Creating shared memory in /dev/shm/org.chromium.heCy9T failed. This is frequently caused by incorrect permissions on /dev/shm.  Try 'sudo chmod 777 /dev/shm' to fix.

In a comment on my blog post (see: http://resa.linux-hardcore.com/?p=512) I was made aware of this bug report. This comment is based on the request as done in comment 10.

After reboot these are the rights that are displayed for /dev/shm
$ ls -lZd /dev/shm
drwxr-xr-x root root unlabeled /dev/shm

I have the latest version of dracut installed (see outcome of yum info dracut):
Loaded plugins: presto, refresh-packagekit
Installed Packages
Name : dracut
Arch : noarch
Version : 004
Release : 4.fc12
Size : 136 k
Repo : installed
Summary : Initramfs generator using udev
URL : http://apps.sourceforge.net/trac/dracut/wiki
License : GPLv2+
Description: dracut is a new, event-driven initramfs infrastructure based around
: udev

Please advise how I could circumvent this issue or let me know if you need more info.
Comment 12 Harald Hoyer 2010-04-29 10:52:53 EDT
(In reply to comment #11)
> I have recently installed Fedora 12 in a separate partition to dual boot it
> with Ubuntu. After installation of Chromium I was confronted with the following
> error:
> 
> [1801:1809:1835452427:FATAL:base/shared_memory_posix.cc(193)] Creating shared
> memory in /dev/shm/org.chromium.heCy9T failed. This is frequently caused by
> incorrect permissions on /dev/shm.  Try 'sudo chmod 777 /dev/shm' to fix.
> 
> In a comment on my blog post (see: http://resa.linux-hardcore.com/?p=512) I was
> made aware of this bug report. This comment is based on the request as done in
> comment 10.
> 
> After reboot these are the rights that are displayed for /dev/shm
> $ ls -lZd /dev/shm
> drwxr-xr-x root root unlabeled /dev/shm

did you recreate your initramfs image?

# dracut -f
Comment 13 Resa Drijsen 2010-04-29 11:13:38 EDT
(In reply to comment #12)
> 
> did you recreate your initramfs image?
> 
> # dracut -f    

I just did, but after rebooting the result remains unchanged:

$ ls -lZd /dev/shm
drwxr-xr-x root root unlabeled                        /dev/shm
Comment 14 Harald Hoyer 2010-04-29 11:22:45 EDT
strange...

$ ls -lZd /dev/shm
drwxrwxrwt root root ?                                /dev/shm
Comment 15 Resa Drijsen 2010-04-29 13:16:52 EDT
Created attachment 410169 [details]
Verbose output of dracut -f

Please find attached the verbose output of the dracut -f command.
Maybe you find something in there that can explain the cause for the fact that I am still having the issue of wrong permission
Comment 16 Resa Drijsen 2010-05-01 14:34:00 EDT
I have been looking into this issue a bit more. Some additional info:
Ubuntu is my main distro with GRUB2 as bootloader.
Ubuntu is installed on /dev/sda1 (/ ext3) and /dev/sda2 (/home ext4).
Fedora is installed on /dev/sda5 (/ ext4) and /dev/sda6 (/home ext4).
/dev/sda3 is swap (for both Ubuntu and Fedora)

In dmesg I find the following comments:
EXT3-fs: sda5: couldn't mount because of unsupported optional features (240).
EXT4-fs (sda5): mounted filesystem with ordered data mode
VFS: Mounted root (ext4 filesystem) readonly on device 8:5.

Although after startup /etc/mtab indicates the following:
$ cat /etc/mtab
/dev/sda5 / ext4 rw 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
devpts /dev/pts devpts rw,gid=5,mode=620 0 0
tmpfs /dev/shm tmpfs rw 0 0
/dev/sda6 /home ext4 rw 0 0
none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
gvfs-fuse-daemon /home/rdrijsen/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,user=rdrijsen 0 0

So it seems that /dev/sda5 (Fedora /) is properly mounted, but dmesg indicates it is mounted readonly.

Could the fact that I still have wrong permissions for /dev/shm be caused by this?

Note You need to log in before you can comment on or make changes to this bug.