Bug 533925 - "yum upgrade udev" (f11 -> rawhide) fails with bluez dependency errors
"yum upgrade udev" (f11 -> rawhide) fails with bluez dependency errors
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-09 14:41 EST by Robert P. J. Day
Modified: 2014-01-21 18:12 EST (History)
11 users (show)

See Also:
Fixed In Version: 145-14.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-27 16:48:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The results of "yum --downloadonly upgrade udev" (98.46 KB, text/plain)
2009-11-09 14:41 EST, Robert P. J. Day
no flags Details
Output of "yum list bluez\*" (2.08 KB, text/plain)
2009-11-09 14:45 EST, Robert P. J. Day
no flags Details

  None (edit)
Description Robert P. J. Day 2009-11-09 14:41:48 EST
Created attachment 368277 [details]
The results of "yum --downloadonly upgrade udev"

On an F11 system with rawhide enabled:

# yum upgrade udev
... big snip, see attached listings ...


Transaction Check Error:
  file /lib/udev/hid2hci from install of udev-145-12.fc12.x86_64 conflicts with file from package bluez-4.42-9.fc11.x86_64
  file /lib/udev/rules.d/70-hid2hci.rules from install of udev-145-12.fc12.x86_64 conflicts with file from package bluez-4.42-9.fc11.x86_64

See attachments.
Comment 1 Robert P. J. Day 2009-11-09 14:44:55 EST
The bluez-related packages already installed on this x86_64 system:

# rpm -qa "*bluez*"
bluez-cups-4.42-9.fc11.x86_64
bluez-4.42-9.fc11.x86_64
bluez-libs-4.42-9.fc11.x86_64
#

See second attachment for output of "yum list bluez\*".
Comment 2 Robert P. J. Day 2009-11-09 14:45:44 EST
Created attachment 368278 [details]
Output of "yum list bluez\*"
Comment 3 Robert P. J. Day 2009-11-09 14:49:45 EST
OK, I just explicitly ran

# yum upgrade bluez\*

that seemed to recognize the newer versions of the three bluez-related packages, and the upgrade is now off and running.  I find that confusing.

Is this ok [y/N]: y
Downloading Packages:
(1/5): bluez-4.57-2.fc12.x86_64.rpm                                         | 340 kB     00:01     
(2/5): bluez-cups-4.57-2.fc12.x86_64.rpm                                    |  27 kB     00:00     
(3/5): bluez-libs-4.57-2.fc12.x86_64.rpm                                    |  72 kB     00:00     
(4/5): gnome-bluetooth-2.28.3-1.fc12.x86_64.rpm                             | 436 kB     00:01     
(5/5): gnome-bluetooth-libs-2.28.3-1.fc12.x86_64.rpm                        |  78 kB     00:00     
---------------------------------------------------------------------------------------------------
Total                                                              248 kB/s | 953 kB     00:03     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating       : glib2-2.22.2-2.fc12.x86_64                                                1/635 
  Installing     : libcom_err-1.41.9-5.fc12.x86_64                                           2/635 
  Updating       : krb5-libs-1.7-8.fc12.x86_64                                               3/635 
  Updating       : openssl-1.0.0-0.10.beta3.fc12.x86_64                                      4/635 
... etc etc ...

  So why weren't the bluez packages picked up during the udev upgrade attempt, since they're clearly dependency-related?
Comment 4 James Antill 2009-11-09 15:49:08 EST
Yum can't do file conflicts ... the packages should have real conflicts, yum see and act on those.
Comment 5 Bastien Nocera 2009-11-09 16:58:01 EST
udev got the new bits, so it should be the one conflicting.

Harald, could you please add a:
Conflicts: bluez < 4.47

This is the version where the hid2hci got moved from bluez to udev.
Comment 6 Fedora Update System 2009-11-11 08:20:25 EST
udev-145-14.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/udev-145-14.fc12
Comment 7 Fedora Update System 2009-11-11 19:50:54 EST
udev-145-14.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update udev'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-11396
Comment 8 Bug Zapper 2009-11-16 10:21:55 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Fedora Update System 2009-11-27 16:47:24 EST
udev-145-14.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.