Bug 534052 - Preupgrade should check for sufficient disk space in advance
Preupgrade should check for sufficient disk space in advance
Status: CLOSED DUPLICATE of bug 530541
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-10 06:35 EST by Kamil Páral
Modified: 2014-01-21 18:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-10 10:14:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error message (76.48 KB, image/png)
2009-11-10 06:35 EST, Kamil Páral
no flags Details
logs (170.00 KB, application/x-tar)
2009-11-10 06:35 EST, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2009-11-10 06:35:07 EST
Created attachment 368368 [details]
error message

Description of problem:
My preupgrade failed because of insufficient disk space on /boot. Couldn't preupgrade check for sufficient disk space in advance, when started using preupgrade command from running environment?

Version-Release number of selected component (if applicable):
anaconda 12.46
preupgrade-1.1.2-1.fc11.noarch

How reproducible:
tried once
 
Actual results:
low disk space is announced after downloading all packages and running the upgrade itself

Expected results:
low disk space is announced right after running preupgrade command in the graphical dialog
Comment 1 Kamil Páral 2009-11-10 06:35:30 EST
Created attachment 368369 [details]
logs
Comment 2 Kamil Páral 2009-11-10 06:40:12 EST
I was preupgrading from Fedora 11 to Rawhide (soon to be released as F12).
Comment 3 Will Woods 2009-11-10 10:11:14 EST
It *does* check for sufficient space, but anaconda uses a different algorithm - it attempts an RPM transaction test, which also does a check for available space.

Preupgrade used the same check as anaconda in the past, but it took several minutes to run and still failed to notice when there was insufficient room on /boot.
Comment 4 Will Woods 2009-11-10 10:14:02 EST

*** This bug has been marked as a duplicate of bug 530541 ***

Note You need to log in before you can comment on or make changes to this bug.