Bug 53406 - Uses always the first received lease-time
Summary: Uses always the first received lease-time
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dhcpcd   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-08 00:25 UTC by Enrico Scholz
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-28 17:00:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2001-09-08 00:25:25 UTC
When the lease-time gets changed on the DHCP-server, dhcpcd ignores these
changes and uses the first lease-time always:


1. configure server to send lease-time of 86400s
2. start dhcpcd (-->will renew in 43200s)
3. reconfigure server to lease-time of 10800s (3h)
4. strace -p `pidof dhcpcd` # (leads to a renew)
   | alarm(43200)                            = 75595

   --> uses still 43200 seconds

   (sniffing the traffic shows that dhcp-option 51 is set to 3h)


This is a nasty bug when used with dynamic DNS updates. Then the host loses
its A and PTR records for some hours, because server deletes them after 3h
but the clients renews them after 12h.

Comment 1 Elliot Lee 2002-01-04 18:29:36 UTC
Hi,
Please test against the dhcpcd-1.3.21pl1 in rawhide, and see if this problem
still occurs.

Comment 2 Enrico Scholz 2002-01-23 13:39:51 UTC
Problem still exists...

Comment 3 Elliot Lee 2002-04-15 16:18:57 UTC
After you changed the lease time on the server, did you have dhcpcd renew the
lease? Just a glaring omission that seemed rather obvious.

There should be a new dhcpcd in rawhide soon that might be worth trying out if
the renewal still uses the old lease time.




Note You need to log in before you can comment on or make changes to this bug.