Bug 534062 - virt-manager does not start qemu-kvm with soundhw parameter.
virt-manager does not start qemu-kvm with soundhw parameter.
Status: CLOSED DUPLICATE of bug 508317
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-10 07:44 EST by Robert Hoekstra
Modified: 2009-11-16 13:56 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-16 13:56:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Hoekstra 2009-11-10 07:44:44 EST
Description of problem:
Creating a VM to run Win7 with audio results in Windows not having any audio device.

Started from virt-manager, the qemu command to start vm is:
/usr/bin/qemu-kvm -S -M pc -m 968 -smp 1 -name win7 -uuid eed882be-5388-bd2a-e339-531e481cfeae -monitor pty -pidfile /var/run/libvirt/qemu//win7.pid -localtime -boot c -drive file=/var/lib/libvirt/images/win7.img,if=ide,index=0,boot=on -drive file=,if=ide,media=cdrom,index=2 -net nic,macaddr=54:52:00:17:e9:1a,vlan=0 -net tap,fd=17,vlan=0 -serial pty -parallel none -usb -usbdevice tablet -vnc 127.0.0.1:0

I miss any sound specifics in the command. (like -soundhw sb16 ), while it is in the gui that it has been assigned. tried both es1370 and sb16 as device.


Version-Release number of selected component (if applicable):
Not sure, it sure applies to virt-manager-0.7.0-7.fc11.i586

How reproducible:
Follow steps below

Steps to Reproduce:
1. Create vm, make sure sound device is added to vm. 
2. start vm 
3. watch 'ps -ef|grep qemu'. seek for any soundhw parameters.
  
Actual results:
qemu-kvm command line without soundhw parameter

Expected results:
qemu-kvm command line WITH soundhw parameter

Additional info:
If anything needed from my side, please let me know.
Comment 1 Andrew McNabb 2009-11-10 18:13:20 EST
Do you have SELinux enabled?  Try adding the following line to /etc/libvirt/qemu.conf:

security_driver = "none"
Comment 2 Robert Hoekstra 2009-11-13 05:21:15 EST
Yes, I am using SELinux . . .

And indeed, the security = none option does invoke the vm with the soundhw parameter.

In that case it seems to be a feature (or more precise, a feature limitation) for when the SELinux security model is activated.. Perhaps this bug could cause a little hint in the GUI to be created stating that sound hardware will not work with the quem SELinux security model enabled or something like that?

Thanks for pointing it out, I don't see how I could have noticed that myself, without digging real deep into the matter..
Comment 3 Andrew McNabb 2009-11-13 11:57:45 EST
Yeah, I would go even further and suggest that "security = none" needs to be the default until the sound problems are fixed.  But no one asked me. :)
Comment 4 Cole Robinson 2009-11-16 13:56:46 EST

*** This bug has been marked as a duplicate of bug 508317 ***

Note You need to log in before you can comment on or make changes to this bug.