Bug 53408 - documentation: screenshot wrongly says /dev/...
documentation: screenshot wrongly says /dev/...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ksconfig (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-07 22:26 EDT by Patrick C. F. Ernzer
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-13 10:40:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick C. F. Ernzer 2001-09-07 22:26:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.3) Gecko/20010803

Description of problem:
The screen for entering partition information and the help file do not make
it clear if e.g. 'dev/sda' od 'sda' has to be used when specifying a disc
to create a partition on. A screenshot states '/dev/sda'. At least on ide
drives, prepending '/dev/' crashes anaconda in kickstart mode, leaving
'/dev/' off allows installation.

Version-Release number of selected component (if applicable):
RE-0831

How reproducible:
Always

Steps to Reproduce:
1. open ksconfig
2. go to Creating Partitions
3. open help text
	

Actual Results:  wrong information in screenshot

Expected Results:
* an example in the help text.
* correct information in screenshot.

Additional info:

logged as 'high' as anaconda crashes with '/dev/hda' but works with 'hda'.
Having no SCSI disk here to test, I can not tell for 100% what happens on
SCSI systems but I'd guess the problem is the same.
Comment 1 Brent Fox 2001-09-12 11:29:55 EDT
It's too late to change things now.  :(  

tfox, how do you think we should address this?  Should we change the docs, or
should we change ksconfig so that you enter '/dev/hda', but then '/dev/' gets
chopped off?  The correct syntax for the kickstart file is to not have the
'/dev/' in the file, which I always thought was counter-intuitive.
Comment 2 Patrick C. F. Ernzer 2001-09-12 12:52:29 EDT
please change the docs, getting ksconfig to chop off stuff will only lead to a
lot of confusion on the user side when seeing the generated file as it will not
represent what was entered.
Comment 3 Tammy Fox 2001-09-13 10:05:43 EDT
This is not in the screenshot for the current version 1.9.8. I will add
information stating that you should not specify the /dev for onpart or ondisk.
Comment 4 Tammy Fox 2001-09-13 10:40:15 EDT
Ok, sorry. I finally see which screenshot you are talking about. I thought you
meant the Creating Partitions screen. I see the /dev/sda in the Partition
Information screen on the top of the page. I changed it and add the text
I mentioned earlier.

Note You need to log in before you can comment on or make changes to this bug.