Bug 534142 - UMS:RS690:X1200 nomodeset crash X
Summary: UMS:RS690:X1200 nomodeset crash X
Keywords:
Status: CLOSED DUPLICATE of bug 533973
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jérôme Glisse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: card_IGP600/MiI
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-10 18:04 UTC by James Hubbard
Modified: 2009-11-17 18:59 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-17 18:59:59 UTC
Type: ---


Attachments (Terms of Use)
Xorg log for crash (46.91 KB, text/plain)
2009-11-10 18:35 UTC, James Hubbard
no flags Details

Description James Hubbard 2009-11-10 18:04:28 UTC
Description of problem:
X crashes when using nomodeset.  Originally, I had only seen this on websites.  However, I started getting this behavior when editing images with gthumb.  I was able to edit one image by using the resize option.  When I try to edit another image, I get get the crash. It doesn't matter what image now.  Any time I right click an imagne and choose open with gthumb a crash occurs.  

Version-Release number of selected component (if applicable):
kernel 2.6.31.5-122.fc12.i686
xorg-x11-drv-ati-6.13.0-0.10.20091006git457646d73.fc12.i686
xorg-x11-server-Xorg-1.7.1-7.fc12.i686

How reproducible:
Once the crash happens, it happens everytime the same way.

Steps to Reproduce:
1. Going to http://www.newegg. will do this everytime.
2.
3.
  
Actual results:
X crashes and returns the login screen

Expected results:
Expect to be able to view websites and open applications.

Additional info:
Added an attachment from Xorg.0.log with seg fault.

Comment 1 James Hubbard 2009-11-10 18:35:00 UTC
Created attachment 368456 [details]
Xorg log for crash

Added log for the Xorg crash.

Comment 2 James Hubbard 2009-11-10 20:49:06 UTC
Some information from the latest crash at the end of dmesg:

[drm] Num pipes: 1
[drm] Setting GART location based on new memory map
[drm] Loading RS690/RS740 Microcode
platform radeon_cp.0: firmware: requesting radeon/RS690_cp.bin
[drm] Num pipes: 1
[drm] writeback test succeeded in 1 usecs
metacity[1723]: segfault at 616d2078 ip 001fa9e1 sp bf9a0b10 error 6 in libSM.so.6.0.0[1f9000+7000]
SELinux: initialized (dev fuse, type fuse), uses genfs_contexts

Comment 3 Jérôme Glisse 2009-11-10 21:28:56 UTC
Do you have any issue with KMS enabled ? Just so you know UMS is not a priority for us.

Comment 4 James Hubbard 2009-11-10 21:45:11 UTC
Yes.  See this bug report.  
https://bugzilla.redhat.com/show_bug.cgi?id=533645

Comment 5 Bug Zapper 2009-11-16 15:24:48 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 6 Jérôme Glisse 2009-11-17 18:59:59 UTC

*** This bug has been marked as a duplicate of bug 533973 ***


Note You need to log in before you can comment on or make changes to this bug.