Bug 534171 - [abrt] crash detected in abrt-gui-0.0.11-1.fc12
Summary: [abrt] crash detected in abrt-gui-0.0.11-1.fc12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jiri Moskovcak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:2f4c7de8
: 529586 537553 540453 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-10 19:52 UTC by Kevin Fenzi
Modified: 2015-02-01 22:49 UTC (History)
23 users (show)

Fixed In Version: 1.0.0-1.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-01 04:38:12 UTC


Attachments (Terms of Use)

Description Kevin Fenzi 2009-11-10 19:52:18 UTC
abrt detected a crash.

Comment
-----
trying to enter bugzilla info. Cancel didn't work, so I closed the entry window and opened it again. 

Attached file: backtrace
cmdline: /usr/bin/python /usr/share/abrt/CCMainWindow.py 
component: abrt
executable: /usr/share/abrt/CCMainWindow.py
kernel: 2.6.31.5-127.fc12.x86_64
package: abrt-gui-0.0.11-1.fc12
uuid: 2f4c7de8

Comment 2 Jiri Moskovcak 2009-11-11 09:13:19 UTC
I can'r reproduce this, can you be more specific about what you did? how did you get to BZ settings window, was it Edit->Plugins or was it from the popup warning you about wrong BZ settings when you clicked "Send"?

Thanks,
Jirka

Comment 3 Kevin Fenzi 2009-11-11 17:27:10 UTC
Sorry, here's the full steps: 

- Clicked on report bug
- Got dialog asking about bugzilla. 
- Clicked on bugzilla button to fill in info. 
- Filled out dialog
- Clicked ok. 
- Had a gnome-keyring issue (it wouldn't unlock). 
- Killed gnome-keyring
- Tried to cancel... wouldn't cancel. Clicked on the close button on the bugzilla info window. 
- Tried clicking on the bugzilla button again. 

Thats where it crashed I think. 

So it might have been how I closed that dialog, or killing gnome-keyring behind it's back?

Comment 4 Jiri Moskovcak 2009-11-12 12:03:22 UTC
The bug came from the backend trying to talk to daemon, so it was probably caused by killing the gk-daemon, but ABRT should survive this, will fix it asap.

Thanks,
Jirka

Comment 5 Orion Poplawski 2009-11-12 18:10:48 UTC
I'm getting this on KDE.  After filling out the bugzilla form, I click apply but nothing happens.

Summary: TB2f4c7de8 ConfBackend.py:68:save:DeniedError

Traceback (most recent call last):
  File "/usr/share/abrt/CCReporterDialog.py", line 113, in on_config_plugin_clicked
    plugin.save_settings()
  File "/usr/share/abrt/ABRTPlugin.py", line 100, in save_settings
    self.Settings.save(str(self.Name))
  File "/usr/share/abrt/ABRTPlugin.py", line 51, in save
    self.conf.save(name, self)
  File "/usr/share/abrt/ConfBackend.py", line 68, in save
    True)
DeniedError

Local variables in innermost frame:
item_list: []
name: Bugzilla
settings: {'NoSSLVerify': 'no', 'Login': 'orion@cora.nwra.com', 'Password': '', 'BugzillaURL': 'https://bugzilla.redhat.com'}
self: <ConfBackend.ConfBackendGnomeKeyring object at 0x8533eec>
password: S()mmer69
settings_tmp: {'AbrtPluginInfo': 'Bugzilla', 'NoSSLVerify': 'no', 'Login': 'orion@cora.nwra.com', 'BugzillaURL': 'https://bugzilla.redhat.com'}

(removed password)

I do have a keyring-daemon running.

Comment 6 Jiri Moskovcak 2009-11-13 12:24:48 UTC
I don't use KDE, so I could miss that problem, but I've heard that KDE and g-keyring doesn't work together too well. I have a plan to write a kwallet backend which should solve this, but it will take some time, so I'll try to reproduce this on KDE and fins some faster solution.

Jirka

Comment 7 Alexey Kuznetsov 2009-11-15 23:13:04 UTC
this is happens on my gnome desktop, not olny kde

Comment 8 Jiri Moskovcak 2009-11-19 09:41:16 UTC
Still can't reproduce this. I can make the gui to survive DeniedError, but I don't understand why it's denied from accessing the keyring.

Jirka

Comment 9 Alexey Kuznetsov 2009-11-19 11:52:40 UTC
if gnome keyring is password protected abrt asks for unlock it, when you hit cancel on open gnome keyring you will got this crash.

Comment 10 Jiri Moskovcak 2009-11-19 12:24:39 UTC
Ah, thanks for the clarification I'll fix this asap.

Jirka

Comment 11 Jiri Moskovcak 2009-11-20 10:15:28 UTC
*** Bug 537553 has been marked as a duplicate of this bug. ***

Comment 12 Jiri Moskovcak 2009-11-22 19:41:20 UTC
*** Bug 529586 has been marked as a duplicate of this bug. ***

Comment 13 Jiri Moskovcak 2009-11-22 19:45:03 UTC
Fixed in git.

Comment 14 Fedora Update System 2009-11-22 20:44:32 UTC
abrt-1.0.0-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/abrt-1.0.0-1.fc12

Comment 15 Jiri Moskovcak 2009-11-23 13:41:15 UTC
*** Bug 540453 has been marked as a duplicate of this bug. ***

Comment 16 Fedora Update System 2009-11-25 15:10:31 UTC
abrt-1.0.0-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update abrt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12098

Comment 17 Fedora Update System 2009-12-01 04:37:15 UTC
abrt-1.0.0-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.