Bug 534193 - (RHQ-1012) agent restart operation should let you provide some additional options
agent restart operation should let you provide some additional options
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Agent (Show other bugs)
unspecified
All All
low Severity low (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
http://jira.rhq-project.org/browse/RH...
: FutureFeature, Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-22 12:17 EDT by John Mazzitelli
Modified: 2014-05-02 16:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-02 16:03:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2008-10-22 12:17:00 EDT
The agent operation "restart" simply restarts the agent with AgentMain.start().

Would be nice to have another operation that lets you specify some (all?) of the command line options you can give the agent.  I don't know if that will be possible, but the use-case that brought this up was to be able to pass --purgedata when restarting (effectively cleaning the inventory and starting fresh).

Maybe we have "clean restart" operation that implies --purgedata.

I don' t think we want to allow a remote "--cleanconfig" because the agent might then lose configuration and not be able to auto-restart (the setup prompts will have to be asked again, unless the agent-config.xml was custom and the user had it fully configured properly - not something we can assume).
Comment 1 Red Hat Bugzilla 2009-11-10 15:21:51 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1012
Comment 2 wes hayutin 2010-02-16 12:08:53 EST
mass add of key word FutureFeature to help track
Comment 3 Corey Welton 2010-08-18 11:13:01 EDT
Mazz, is this a quick win/change?  Otherwise, let's close.
Comment 4 John Mazzitelli 2010-08-24 13:38:08 EDT
I think this could be a quick win for us - if we do this:

"Maybe we have "clean restart" operation that implies --purgedata."

This means we just add a new operation to the agent plugin that purges the data directory prior to starting the agent VM back up.

This is low priority however.

Note You need to log in before you can comment on or make changes to this bug.