Bug 534221 - (RHQ-1038) Have control over link generated by jopr
Have control over link generated by jopr
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
unspecified
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
http://jira.rhq-project.org/browse/RH...
: FutureFeature
Depends On:
Blocks: jon3
  Show dependency treegraph
 
Reported: 2008-11-03 05:12 EST by Jean Deruelle
Modified: 2013-12-07 14:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-07 14:12:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jean Deruelle 2008-11-03 05:12:00 EST
I would like to do another service which checks through JMX for an  application and if it's available, I would like to display a link.
 I know that I can do this pretty easily with jopr but the caveat  here is I would like to have control over the link, so that instead  of being generated by jopr I would like to generate it.
The use case for this is that we have a management console which  embeds some AJAX stuff etc.. and I guess that integrating it into  jopr would not be possible so I would like to link to it from Jopr  
so that users have only one link to remember for Management  Operations.
Comment 1 John Mazzitelli 2008-11-03 08:09:20 EST
I'm not sure what link you are refering to, but since you mention "display" a link - you are talking about customizing the GUI.

The way we are going to allow RHQ to be extensible like this is to allow developers to write their own GUIs via our web service APIs. See the design document:

http://support.rhq-project.org/display/RHQ/Design-API

A few months ago, we had a prototype GUI written in Python that accessed the RHQ server APIs via web services that showed this is possible.  Based on that previous experience, we've written up that design document and will be implementing some of that soon.
Comment 2 Jean Deruelle 2008-11-03 09:25:37 EST
Hi, this is interesting but not what I want. I think the confusion stems from the fact that I said we have a AJAX management console too and that it could be tied into jopr.
But I would just like to link to my own custom management appication from jopr not redo the whole jopr GUI, I think you guys did a pretty good job at it.
What I would like to do is basically :

Create a new service in my jopr custom plugin. This service will check the availability of a specific web application (let's say custom-management-console.war )
If it is not available, nothing is changed in the JBoss Administration console). If it is available however I would like to have a link (let's say somewhere under Services like 'MobicentSipServlets' or 'Connector' - see http://www.mobicents.org/mss-embjopr-home.png)  and this link instead of being generated by jopr and point within the jopr web context (like http://localhost:8080/embedded-jopr/secure/summary.seam?conversationId=6&path=-4%2FConnector&conversationPropagation=end), I would like that the service can link to an another web context like http://localhost:8080/custom-management-console. So I would like to be able to personalize the link so that instead of linkiing to http://localhost:8080/embedded-jopr/secure/summary.seam?conversationId=6&path=-4%2FConnector&conversationPropagation=end it would link to http://localhost:8080/custom-management-console.

I hope this is a bit clearer

Comment 3 Red Hat Bugzilla 2009-11-10 15:22:31 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1038
Comment 4 Heiko W. Rupp 2013-12-07 14:12:13 EST
Though it is a valid request, I am closing this for now - and if only as Jopr and the embedded Console no longer exists.
We will in some future version of RHQ offer a possibility for agent plugins to define some soft of UI plugin that is not only a link to some other tool, but can also hook into menu structures etc.

Note You need to log in before you can comment on or make changes to this bug.