This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 534240 - (RHQ-1055) support more sophisticated alerts around measurement traits
support more sophisticated alerts around measurement traits
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Alerts (Show other bugs)
unspecified
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Charles Crouch
http://jira.rhq-project.org/browse/RH...
: FutureFeature
Depends On:
Blocks: rhq4
  Show dependency treegraph
 
Reported: 2008-11-04 14:21 EST by Joseph Marques
Modified: 2015-02-01 18:24 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-11 16:25:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph Marques 2008-11-04 14:21:00 EST
today we can alert on trait changes.  tomorrow we could support...

new value matches a particular substring
new value startswith a particular substring
new value endswith a particular substring
new value endswith a particular regular expression

all of these more advanced matches would be similar to how we do advanced processing on the "details" field for events-based alerting.  with it we'll be able to:

* alert when the RHQ Agent "restart reason" trait substring-matches "memory", i.e. one of my agents was automatically restarted due to OOME or perm gen issues
* alert when the JBossAS Server "version" string regex-matches "cluster[0-9][0-9]", i.e. one of my jboss servers has changed partition memberships
Comment 1 Red Hat Bugzilla 2009-11-10 15:22:54 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1055
Comment 6 Jay Shaughnessy 2011-02-11 16:25:12 EST
Will revisit given customer demand.

Note You need to log in before you can comment on or make changes to this bug.