Bug 534254 - (RHQ-1068) JMX plugin cann't obtain list of registered loggers from JMX Server
JMX plugin cann't obtain list of registered loggers from JMX Server
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
1.1
All All
low Severity medium (vote)
: ---
: ---
Assigned To: Heiko W. Rupp
http://jira.rhq-project.org/browse/RH...
: SubBug
Depends On:
Blocks: rhq_triage
  Show dependency treegraph
 
Reported: 2008-11-06 04:42 EST by Andrii Khaisin
Modified: 2014-05-02 16:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
svn revision of JavaUtilLoggingResourceComponent is 7
Last Closed: 2014-05-02 16:10:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
agent.log (121.94 KB, text/plain)
2008-11-06 08:34 EST, Andrii Khaisin
no flags Details
server.log (1.58 KB, text/plain)
2008-11-06 08:34 EST, Andrii Khaisin
no flags Details

  None (edit)
Description Andrii Khaisin 2008-11-06 04:42:00 EST
"Configuration isn't initialized" message on Configure page for Logging service.
It is because of infinite recursion in JavaUtilLoggingResourceComponent.getLoggerLevel(..).
Comment 1 Heiko W. Rupp 2008-11-06 06:57:10 EST
Hello,
can you please provide the agent log (if it shows any errors) and/or rhe server log, as this sometimes also contains a stack trace when the configuration can't be loaded.

What infinite recursion do you mean? 
Comment 2 Andrii Khaisin 2008-11-06 08:34:26 EST
Here is attached agent and server log. There is java.lang.StackOverflowError.
I've investigated rhq-jmx-plugin-1.1.0.GA in debug mode for dynamically changing of configuration. Target JMX Server was started in fresh tomcat 6.0.18. Sources of plugin has been taken from RHQ SVN.
JavaUtilLoggingResourceComponent.getLoggerLevel can't exit from recursive calls when LoggingMXBean.getParentLoggerName return zero string for a root loggers in hierarchies. 
Comment 3 Red Hat Bugzilla 2009-11-10 15:23:13 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1068
Imported an attachment (id=368490)
Imported an attachment (id=368491)
Comment 4 wes hayutin 2010-02-16 11:56:42 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 5 wes hayutin 2010-02-16 12:01:57 EST
making sure we're not missing any bugs in rhq_triage

Note You need to log in before you can comment on or make changes to this bug.