Bug 53428 - Installer freezes comp when trying to format swap space
Installer freezes comp when trying to format swap space
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-08 12:59 EDT by gehan gehale
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-15 15:39:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gehan gehale 2001-09-08 12:59:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)

Description of problem:
When I try to install RedHat 7.1 from CD I get a system freeze when it 
trys to format the swap space(400 MB).
 On the last option when it format's the partitions it goes through the 
other drives and get's through them fine, When it get's to the last one
(swap) it freezes. I've tried useing fdisk and druwid, also varying 
configs such as makeing 3 drives or 4, swap first to format or last... 
Same result..

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start anaconda
2. Fdisk one swap partition(400 MB) and 1 linux native (1.2 GB)
3. Continue install, right before packages install, it tries to format 
swap the partition, after or before native partition

Actual Results:  System hangs with a thin green line appearing across top 
of screen. No mouse or keyboard input recognized. No system beeps, nothing.
 The green line isn't new or part of the problem. That always happens when 
I get a system crash.. Your results may varry...

Expected Results:  Shoud have formated swap partition and installed 
packages

Additional info:
Comment 1 gehan gehale 2001-09-09 02:21:09 EDT
I have figured out that it's not actually the swap partition that's causeing 
the freeze. It's the package install.. If I install 5.1 and then start the 7.1 
install under upgrade option it asks's me first to increase swap size, or skip 
that step.. If I skip that step it will start installing packages. Then 
randomly lock up during different package installs.. Sometimes at 20%, 45% the 
most I got was 60%....
Comment 2 gehan gehale 2001-09-09 12:51:27 EDT
 I have also done a md5check sum on my iso files before I burned them.. They 
check out ok...

 Any that can help please do, This is frustutating. I really want to get 7.1 up 
and running...
Comment 3 gehan gehale 2001-09-10 00:49:29 EDT
I currently have RH 5.1 installed on my comp.I've tried as an clean install or 
as an upgrade. I start the install either way by booting the comp with a win 98 
bootdisk and then going to /dosutils and running autoboot...

 Since I have RH 5.1 on my sytem is there a way to start the install from 
linux? maybe that would work better?
Comment 4 Matt Wilson 2001-09-10 09:53:46 EDT
you skipped adding swap?  If so, your machine is running into VM corner cases
because you did not add swap.
Comment 5 gehan gehale 2001-09-10 12:17:28 EDT
 I've gotten it to increace the file.. One time I clicked skip to see what it 
would do and it did the same thing.. LOCK UP
Comment 6 Brent Fox 2001-09-10 18:52:22 EDT
Yes, it's probably going to lock up if it runs out of swap.  
Here's a few questions:

1) How much RAM do you have in your machine?  

2) How much swap do you have configured for your 5.1 system?

3) How big did you set the swap file to be during the upgrade?
Comment 7 gehan gehale 2001-09-10 19:02:32 EDT
I have 128 MB of ram in my computer.. is a dell dimention with a P2 500 in it, 
9GB hard drive, one cd rom, one floppy, nothing out of the ordanery...

 My 5.1 wouldn't let me go higher then 126 which is what I used...

 When I get to the swap part of 7.1 install it suggestes 532 I think it was.. 
off the top of my head I know it was around 500 or so....

So I set it at the default suggested value (532)
Comment 8 gehan gehale 2001-09-14 03:43:44 EDT
I have submited a new bug number: 53658 detailing my attepmts to install 7.1 
upgrade over 5.1, a very though discription please read...
Comment 9 Brent Fox 2001-10-04 14:24:10 EDT
I don't know what the problem could be.  I have Dell machines that I do testing
on all the time, and I can't reproduce the behavior you are seeing.  What about
trying a fresh install?
Comment 10 Brent Fox 2001-10-15 12:25:01 EDT
Any more info here?
Comment 11 gehan gehale 2001-10-15 15:39:10 EDT
There is no info to provide.. I gave up and installed manhatten.. thanks 
anyway...
Comment 12 Brent Fox 2001-10-16 11:31:13 EDT
Ok.  Closing as worksforme.

Note You need to log in before you can comment on or make changes to this bug.