This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 534287 - (RHQ-1099) Error processing Web Service return value for updateConfiguration services
Error processing Web Service return value for updateConfiguration services
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: No Component (Show other bugs)
1.2
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
http://jira.rhq-project.org/browse/RH...
: SubBug
Depends On:
Blocks: RHQ-2202 rhq_triage
  Show dependency treegraph
 
Reported: 2008-11-10 15:18 EST by Jay Shaughnessy
Modified: 2014-05-02 16:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-02 16:12:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jay Shaughnessy 2008-11-10 15:18:00 EST
The updateConfiguration API calls return PluginResourceUpdate or ResourceConfigurationUpdate depending on the config type. When called remotely via jbossws we get an error:

[com.sun.istack.SAXException2: A cycle is detected in the object graph. This will cause infinitely deep XML: ResourceConfigurationUpdate[status=In Progress,
configuration=Configuration[id=503052, notes=null], 
  subjectName=ws-test,   
  createdTime=1226344038239, 
  modifiedTime=1226344038240, 
  errorMessage=null,
  id=501051,
  resource=Resource[id=500055,   *************** LOOKS LIKE THIS RESOURCE RECURSES **************
    type=JBossAS Server, 
    key=C:\Eclipse-ws\rhq\dev-container\jbossas\server\default, 
     name=jshaughnessy-PC RHQ Server,  
    JBossAS 4.2.1.GA default (0.0.0.0:2099), 
    version=4.2.1.GA]] -> 
       Resource[id=500055, *************** HERE IT IS AGAIN ***************
       type=JBossAS Server, 
       key=C:\Eclipse-ws\rhq\dev-container\jbossas\server\default, 
       name=jshaughnessy-PC RHQ Server,  
      JBossAS 4.2.1.GA default (0.0.0.0:2099), 
      version=4.2.1.GA] ->  
        ResourceConfigurationUpdate[status=In Progress,configuration=Configuration[id=503052, 
        notes=null], subjectName=ws-test,createdTime=1226344038239, 
        modifiedTime=1226344038240, 
        errorMessage=null, id=501051, 
        resource=Resource[id=500055,   *************** AGAIN ***************
          type=JBossAS Server, 
          key=C:\Eclipse-ws\rhq\dev-container\jbossas\server\default, 
          name=jshaughnessy-PC RHQ Server,  
         JBossAS 4.2.1.GA default (0.0.0.0:2099), version=4.2.1.GA]]]

The update succeeds, this is in the return processing
Comment 1 Jay Shaughnessy 2008-11-20 15:28:30 EST
This most likely needs judicious placement of an @XmlTransient
Comment 2 Jay Shaughnessy 2009-06-30 13:41:26 EDT
We're first working to get java clients working via jboss remoting.  After that we'll revisit WS clients and jaxb serialization issues.
Comment 3 Red Hat Bugzilla 2009-11-10 15:23:54 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1099
Comment 4 wes hayutin 2010-02-16 11:59:31 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 5 wes hayutin 2010-02-16 12:04:40 EST
making sure we're not missing any bugs in rhq_triage
Comment 6 Corey Welton 2010-08-18 11:15:57 EDT
jshaugh, is this still an issue?

Note You need to log in before you can comment on or make changes to this bug.