Bug 534313 - (RHQ-1121) temporarily reject registrations if server is getting too many
temporarily reject registrations if server is getting too many
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Agent (Show other bugs)
unspecified
All All
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
http://jira.rhq-project.org/browse/RH...
: FutureFeature, Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-14 13:42 EST by John Mazzitelli
Modified: 2010-08-24 13:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-24 13:39:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2008-11-14 13:42:00 EST
When the RHQ Server gets clobbered with lots of agent registration requests (such as when you start a large amounts of agents at the same time), the server bogs down.  This is because, not only is there lots of registrations coming, but soon, tons of inventory reports will also be coming.

I'm not sure if we should try to some how throttle these new agents. Perhaps add a new concurrency limit classification for registration messages? Or something similar that slows down the influx of new agents.
Comment 1 Red Hat Bugzilla 2009-11-10 15:24:24 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1121
Comment 2 wes hayutin 2010-02-16 12:09:50 EST
mass add of key word FutureFeature to help track
Comment 3 Corey Welton 2010-08-18 11:17:21 EDT
mazz, is this still an issue?
Comment 4 John Mazzitelli 2010-08-24 13:39:34 EDT
i would close this. we've not seen any problems with the server unable to handle a flood of registration requests. we do throttle other things like inventory reports.

Note You need to log in before you can comment on or make changes to this bug.