Bug 53432 - wvdial retries forever on busy or no dialtone
Summary: wvdial retries forever on busy or no dialtone
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: wvdial (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 79677 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-08 19:22 UTC by Kenn Humborg
Modified: 2007-04-18 16:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-08 15:30:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add "abort on busy" and "abort on no dial tone" options (3.08 KB, patch)
2001-09-08 19:22 UTC, Kenn Humborg
no flags Details | Diff

Description Kenn Humborg 2001-09-08 19:22:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.16-kh5 i686; en-US; rv:0.9.1)
Gecko/20010621

Description of problem:
If the modem is not connected, the destination number 
is busy or the line is currently in use at another
extension, wvdial will always redial forever.  I've
patched wvdial to add "abort on busy" and "abort on 
no dial tone" options that allow the user to disable
this automatic retrying.

Patch will be attached.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Disconnect the phone line from the modem
2. /sbin/ifup ppp0
3. wvdial tries every 5 seconds until you take down ppp0
	

Additional info:

Comment 1 Kenn Humborg 2001-09-08 19:22:49 UTC
Created attachment 31354 [details]
Patch to add "abort on busy" and "abort on no dial tone" options

Comment 2 Kenn Humborg 2001-09-08 19:24:02 UTC
BTW, wvdial development seems to have stopped.  This is why
I'm passing the patch to you guys rather than the author.


Comment 3 Harald Hoyer 2004-09-21 14:46:38 UTC
*** Bug 79677 has been marked as a duplicate of this bug. ***

Comment 4 Kenn Humborg 2004-09-21 15:23:28 UTC
Please note that bug 79677 was not the same behaviour as this
bug.  Bug 79677 describes a very quick retry (less than 1 second)
which doesn't wait long enough for the far side to answer.

In my case, wvdial continued to redial, as normal, when the 
modem replied BUSY or NO DIAL TONE.  In many cases, this is
correct, desired behaviour.

However, in my case, I share the phone line with other people in
the house.  When they are on a call, I would like wvdial to only
try dialling once, then give up.  Hence my patch to add the
ABORT ON BUSY and ABORT ON NO DIAL TIME options.


Comment 5 Harald Hoyer 2005-07-08 15:30:09 UTC
should work with current versions


Note You need to log in before you can comment on or make changes to this bug.