Bug 53435 - usb.agent uses -ge instead of -gt; PATCH INCLUDED
usb.agent uses -ge instead of -gt; PATCH INCLUDED
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: hotplug (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-08 15:27 EDT by Mark Lord
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-12 11:04:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bugfix for /etc/hotplug/usb.agent (391 bytes, patch)
2001-09-08 15:28 EDT, Mark Lord
no flags Details | Diff

  None (edit)
Description Mark Lord 2001-09-08 15:27:26 EDT
Description of Problem:
/etc/hotplug/usb.agent uses -ge instead of -gt when comparing
device numbers, which causes recognition of support devices to fail
incorrectly (e.g. Lexar Jumpshot USB with 2.4.9-ac10 kernel).

Version-Release number of selected component (if applicable):
hotplug-2001_04_24-9

How Reproducible:
1oo%

Steps to Reproduce:
1. insert a Lexar JumpShot CompactFlash USB card/cable into USB port while 
running a kernel which includes the driver module for this (latest -ac series).
Other devices may also fail due to the same bug.
2. look in /var/log/messages and note the "/etc/hotplug/usb.agent: ... no 
drivers for USB product 5dc/1/1" message.
3. look in /lib/modules/`uname -r`/modules.usbmap and ensure an entry 
exists for this product.

Actual Results:


Expected Results:


Additional Information:
 Patch to fix the problem (one-liner) is attached.
Comment 1 Mark Lord 2001-09-08 15:28:13 EDT
Created attachment 31355 [details]
bugfix for /etc/hotplug/usb.agent
Comment 2 Trond Eivind Glomsrxd 2001-09-08 16:41:33 EDT
usb.agent isn't used anymore - it uses usbmodules. Will fix it anyway, though.
Comment 3 Trond Eivind Glomsrxd 2001-09-25 14:05:03 EDT
Added to  2001_04_24-12. Could you submit it to the usb mailing list as well? 
linux-hotplug-devel@lists.sourceforge.net. TIA.

Note You need to log in before you can comment on or make changes to this bug.