Bug 534363 - (RHQ-1167) totalMemory platform metric should be trait, or at least not collected alot
totalMemory platform metric should be trait, or at least not collected alot
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
unspecified
All All
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Corey Welton
http://jira.rhq-project.org/browse/RH...
: FutureFeature, Improvement
Depends On: RHQ-1744
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-22 15:00 EST by John Mazzitelli
Modified: 2011-05-23 21:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (131.95 KB, image/png)
2010-10-25 05:13 EDT, Sunil Kondkar
no flags Details
Screenshot of collection interval in RHQ4 RC1 (95.26 KB, image/png)
2011-05-02 09:20 EDT, Mike Foley
no flags Details

  None (edit)
Description John Mazzitelli 2008-11-22 15:00:00 EST
I noticed that my "total memory" metric for my platform is collected every 2 minutes.

This seems like it should be a trait - since this will only ever change if someone adds more physical memory to the system.

At the very least, we should not be collecting this every 2 minutes.  Every 10 mins or maybe 60 minutes.
Comment 1 Red Hat Bugzilla 2009-11-10 15:27:11 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1167
Comment 2 wes hayutin 2010-02-16 12:10:22 EST
mass add of key word FutureFeature to help track
Comment 3 Corey Welton 2010-08-18 11:07:52 EDT
Moved to ONQA for further examination.  For this issue, we just need to find what the current setting is, assign it back, and link to bug #535003
Comment 4 Sunil Kondkar 2010-10-25 05:11:44 EDT
Tessted on RHQ build#446

The current setting for 'Total Memory' metric for platform is:
Type = Measurement
Collection Interval = 2 Minutes
Please refer the attached screenshot.

Moving this to ON_DEV as per 'comment 3' and linking this bug to bug #535003.
Comment 5 Sunil Kondkar 2010-10-25 05:13:35 EDT
Created attachment 455441 [details]
Screenshot
Comment 6 John Mazzitelli 2011-02-16 09:47:33 EST
git 21fe21c68b7cc5b2f7af3278d15dc2a4ef5ae584

added:

defaultInterval="1200000"

to the Total Memory and Total Swap Space metrics so they are now collected every 20m, as opposed to every 2m.
Comment 7 Mike Foley 2011-05-02 09:20:21 EDT
Created attachment 496257 [details]
Screenshot of collection interval in RHQ4 RC1

this screenshot shows 2 minutes, not the expected 20 minute
Comment 8 John Mazzitelli 2011-05-02 09:32:21 EDT
I just confirmed it working correctly on my install of the 4.0.0 release candidate.

Mike - I think this is "broke" for you because you are testing an upgrade from 3.0.0 where the default was still 2m. We don't override defaults on existing resources even after upgrading to a new plugin with a new default.

you'll have to test this from a fresh install (non-upgrade) - when I did this, I see the default as 20m.
Comment 9 Mike Foley 2011-05-02 09:49:47 EDT
ah ....  thx.  will retest.
Comment 10 Corey Welton 2011-05-23 21:17:27 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 11 Corey Welton 2011-05-23 21:17:27 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 12 Corey Welton 2011-05-23 21:17:27 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 13 Corey Welton 2011-05-23 21:17:29 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.