Bug 534398 - (RHQ-1199) have CommandProcessor expose calltime metrics for each command type
have CommandProcessor expose calltime metrics for each command type
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Communications Subsystem (Show other bugs)
unspecified
All All
low Severity medium (vote)
: ---
: ---
Assigned To: John Mazzitelli
Jeff Weiss
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-01 10:51 EST by John Mazzitelli
Modified: 2014-11-09 17:48 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2008-12-01 10:51:00 EST
Currently, CommandProcessor collects average execution time metrics for successfully executed commands. But on a stable system, the value is usually "0" or close to it because the majority of its messages are pings and are very fast.

It would be nice to have it collect metrics on a per command type (and for remote pojos, collect down to the method being invoked).
Collect:

command type|sub command type|max time|min time|average time

Have aggregated RemotePojo invocations but the sub command type would be the class.method name
Comment 1 John Mazzitelli 2008-12-02 02:56:14 EST
svn rev2159

we now have calltime metrics being collected for each individual command type/remote pojo. for use with rhq-plugin (see https://jira.jboss.org/jira/browse/JOPR-30)
Comment 2 John Mazzitelli 2008-12-02 03:28:57 EST
svn rev2160 fixes a bug in the 2159 checkin. therefore, 2160 goes hand in hand with 2159
Comment 3 Jeff Weiss 2009-02-09 12:01:35 EST
The testing for rhq-1234 incorporates testing for this jira.  closing, rev2894
Comment 4 Red Hat Bugzilla 2009-11-10 15:27:54 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1199
This bug relates to RHQ-1234

Note You need to log in before you can comment on or make changes to this bug.