Bug 534400 - (RHQ-11) embedded agent's platform name should have a better default
embedded agent's platform name should have a better default
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Agent (Show other bugs)
unspecified
All All
low Severity medium (vote)
: ---
: ---
Assigned To: John Mazzitelli
Pavel Kralik
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-28 09:38 EST by John Mazzitelli
Modified: 2013-04-30 19:32 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2008-02-28 09:38:00 EST
The plugin discovery component used to name the platform resource as the hostname.  This had some problems so we changed it to be the agent name as the platform resource name.

Using the agent name in platform names is because the agent's name is really the only thing the user has control over and sometimes hostnames are not descriptive enough. An added benefit is that the platforms would have different names in performance test configurations where you run multiple agents on the same box (when I ran hundreds-of-agents on a box, all the platforms had the same name and you couldn't distinguish them).

All that said, I can see it being annoying that the embedded agent will have its platform named "embedded agent".

So, if the agent name is the same as the host name (as is normally the case, but you are not guaranteed this to be true) we'll make the resource name the same as the host name (which happens to be the same as the agent name).

If however the agent name is DIFFERENT than the hostname, we'll make the platform resource name be the hostname appended with " (<agent-name>)" so you can distinguish it in the UI.

Obviously, the user can edit the resource name however they want via the Inventory tab once its in inventory, but these are good defaults.
Comment 1 John Mazzitelli 2008-02-28 09:46:16 EST
rev80
Comment 2 John Mazzitelli 2008-02-28 09:58:44 EST
The problem is that the agent name that the user types in is supposed to be the way we let the user name their platform. e.g. in dhcp setups the hostname is often useless or localhost.localhost or some such thing. 

We should just default the agent's name to always be hostname (default, but the user can override).
Comment 3 John Mazzitelli 2008-02-28 10:14:40 EST
The problem that is really happening now is the embedded agent doesn't default to the hostname (like standalone agent does).  Defaulting the platform resource name to agent name is fine in the standalone agent case because it defaults to the hostname, which is usually want you want.

In the embedded agent case, the installer's form field defines the default agent name and its always "embedded".  We need to somehow get this to default to the hostname. I thought using ${jboss.bind.address} would be the easiest way to do it. So when the user enters the bind address in the installer or sets the bind address in rhq-server.properties, they are also going to implicitly define the name of the embedded agent.  Of course, user can change the string "${jboss.bind.address}" to some other name if they want to call their embedded agent something else.

${jboss.bind.address} isn't optimal either - since it could conceivably be "0.0.0.0" or something equally useless as an agent name.  But it needs to be static because it has to ship in rhq-server.properties (that's how the installer works, I don't think it'll be trivial to change the way the installer pre-populates the form field in the browser to some runtime/dynamically-generated value).
Comment 4 John Mazzitelli 2008-12-12 15:42:18 EST
embedded agent name now defaults to the machine name followed by "-embedded".
Comment 5 Pavel Kralik 2009-02-11 09:29:05 EST
Tested with the embedded and standalone agent. They had different names in the server log file.

RHEL5.3, x86_64, PostgreSQL8.2.4, java 1.6.0_11, JON RHQ SVN rev# 2894 
Comment 6 Red Hat Bugzilla 2009-11-10 15:27:56 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-11
This bug is incorporated by RHQ-1253

Note You need to log in before you can comment on or make changes to this bug.