Bug 534427 - (RHQ-1223) have default communicator.bind-address be null so agent picks up the system IP
have default communicator.bind-address be null so agent picks up the system IP
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Agent (Show other bugs)
unspecified
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: John Mazzitelli
http://jira.rhq-project.org/browse/RH...
: SubTask
Depends On:
Blocks: RHQ-1016
  Show dependency treegraph
 
Reported: 2008-12-07 01:12 EST by John Mazzitelli
Modified: 2009-11-10 16:22 EST (History)
0 users

See Also:
Fixed In Version: 1.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2008-12-07 01:12:00 EST
When the agent asks its startup setup questions, it defaults the agent bind-address to the getLocalHost() IP. But once you accept that setup question default, that value is explicitly set in the preferences.  If that agent's default IP later changes (where getLocalHost() returns a different IP) the agent will be dead in the water because you hard-configured it to use the old IP.

Change the setup question default to be "null", which means to fallback to the system default and leave the preference undefined.

We already have this capability to do this today, but the user must know enough to enter "!*" at the setup prompt (as the setup help instructions say at the top of the setup question prompts). Most people don't know to do this nor do they know the implications. However, in this case of agent bind-address, this should really be the default so the user just hits "enter", accepts that as the default, and now the agent will be tolerant of IP changes. The user must explicitly type in an IP if they want to override this behavior.

This relates to the parent issue, but doesn't fix it all the way. But its nice that now you don't have to reconfigure the agent explicitly - when the agent restarts, it'll pick up its new IP automatically. Only when you want to override the default IP with one explicitly, will you have to reconfigure the agent yourself.

The parent issue still occurs if the agent's new IP was once another agent's IP. It is under those situations where manual intervention is needed.
Comment 1 Red Hat Bugzilla 2009-11-10 15:28:28 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1223

Note You need to log in before you can comment on or make changes to this bug.