Bug 534432 - (RHQ-1228) don't show null as the default setup answer, use a different string to indicate it
don't show null as the default setup answer, use a different string to indica...
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Agent (Show other bugs)
unspecified
All All
low Severity medium (vote)
: ---
: ---
Assigned To: John Mazzitelli
Corey Welton
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-08 14:57 EST by John Mazzitelli
Modified: 2009-02-09 09:23 EST (History)
0 users

See Also:
Fixed In Version: 1.2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2008-12-08 14:57:00 EST
(2:53:35 PM) joseph: mazz, my new agent now has a default IP of "null"
(2:53:37 PM) joseph: is that right?
(2:54:17 PM) mazz: http://jira.rhq-project.org/browse/RHQ-1223
(2:54:37 PM) mazz: yes, it is right.  I should probably not show the string "null" - maybe just an empty string 
(2:54:39 PM) joseph: very well
(2:54:43 PM) mazz: but for now, it is what it is
(2:54:46 PM) joseph: i did see that jira, but iddn't recall "null" being right
(2:54:56 PM) joseph: you should change that to some other special char
(2:55:02 PM) joseph: that will no doubt confuse users
(2:55:14 PM) mazz: yes, which is what I tried to say above
(2:55:38 PM) mazz: probably should show "!*"
(2:55:50 PM) mazz: since that's the special marker to indicate we fallback to system defaults
(2:55:56 PM) mazz: either that or just an empty string
(2:56:25 PM) joseph: or maybe something like "dynamic", "non-static", "rotating", "changes", etc
Comment 1 John Mazzitelli 2008-12-09 22:53:46 EST
instead of showing the string "null", we show the "!*" string since this is the notation that the user must enter to set the value as the internal default (which is what null represents in this context)
Comment 2 Corey Welton 2009-02-09 09:23:02 EST
QA Verified, we now use !* for indication.
Comment 3 Red Hat Bugzilla 2009-11-10 15:28:34 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1228

Note You need to log in before you can comment on or make changes to this bug.