Bug 534450 - (RHQ-1244) should we enable heap-dump-on-error in both agent and server?
should we enable heap-dump-on-error in both agent and server?
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Documentation (Show other bugs)
unspecified
All All
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
http://jira.rhq-project.org/browse/RH...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-10 10:40 EST by John Mazzitelli
Modified: 2014-05-02 16:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-02 16:38:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2008-12-10 10:40:00 EST
Should we start the server and agent with the following VM parameters:

-XX:+HeapDumpOnOutOfMemoryError writes heap dump on OutOfMemoryError (recommended)
-XX:+HeapDumpOnCtrlBreak writes heap dump together with thread dump on CTRL+BREAK 

See: http://wiki.eclipse.org/index.php/MemoryAnalyzer

These are only valid for SUN HotSpot VMs, but since it covers the majority of people's VMs, it might be useful to have this turned on by default in our launcher scripts/configuration.

Comment 1 Red Hat Bugzilla 2009-11-10 15:28:56 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1244
Comment 2 Corey Welton 2010-08-06 09:08:17 EDT
Per triage, we are going to doc this for now, provide information on how to enable if necessary.  Deon, please talk with developer to determine the best place to put this, and how to word it.
Comment 3 Deon Ballard 2010-08-06 09:42:19 EDT
I'm changing the component to Documentation for the moment, so it shows up in my queue and I don't forget about it.
Comment 4 Joseph Marques 2010-08-09 00:29:06 EDT
Here is the reference we can include in our documentation
http://www.oracle.com/technetwork/java/javase/tech/vmoptions-jsp-140102.html#DebuggingOptions

We would suggest to people, if they are seeing the server crash due to 
OutOfMemoryError issues, to restart with the following VM options:

-XX:-HeapDumpOnOutOfMemoryError

If the user wants the heap dump file to be dropped in a particular location, 
they can additionally specify:

-XX:HeapDumpPath=./java_pid<pid>.hprof

Note You need to log in before you can comment on or make changes to this bug.