Bug 534472 - (RHQ-1265) migitate issue in 1_1_2_GA_CP branch by eliminate the ajax-y indicator chart refresh
migitate issue in 1_1_2_GA_CP branch by eliminate the ajax-y indicator chart ...
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Monitoring (Show other bugs)
1.1.2
All All
high Severity medium (vote)
: ---
: ---
Assigned To: Joseph Marques
Corey Welton
http://jira.rhq-project.org/browse/RH...
: SubBug
Depends On:
Blocks: RHQ-1002
  Show dependency treegraph
 
Reported: 2008-12-15 15:50 EST by Joseph Marques
Modified: 2010-02-16 16:10 EST (History)
0 users

See Also:
Fixed In Version: 1.1.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph Marques 2008-12-15 15:50:00 EST
the problem here is exacerbated by the fact that each indicator chart has an individual refresh internal, which defaults to 60 seconds.  this wouldn't be so bad if the refresh countdown began AFTER each chart finished rendering, but that's not how it works.  instead, the 60 second interval is mapped to the clock on the wall, so if it takes 55 seconds to generate the graph, it will refresh 5 seconds later.  if it takes longer than 60 seconds to generate the graph, it will put constant load on the database without ever generating anything (because by the time one chart is generated, it's auto-refreshing-div element has already requested new data and discarded the previous request).
Comment 1 Joseph Marques 2008-12-15 16:55:12 EST
rev2406 - do not load the method that registers the refresh callback; 
Comment 2 Corey Welton 2008-12-17 15:41:45 EST
QA Verified, we're no longer refreshing the chart every minute or so, in the CP build.
Comment 3 Red Hat Bugzilla 2009-11-10 15:29:21 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1265
Comment 4 wes hayutin 2010-02-16 16:10:14 EST
Mass move to component = Monitoring

Note You need to log in before you can comment on or make changes to this bug.