Bug 53448 - qt designer compiled without kde support
Summary: qt designer compiled without kde support
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: qt (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-09 06:16 UTC by Sagi Bashari
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-09 06:16:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sagi Bashari 2001-09-09 06:16:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010808

Description of problem:
Hi,

The QT package in Roswell 2 was not compiled with KDE support which means
you cannot use KDE widgets inside QT designer.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:

	1. Start QT designer
2. KDE should apper until tools, but it's not in roswell.

Additional info:

Comment 1 Bernhard Rosenkraenzer 2001-09-09 20:31:09 UTC
This is because the distribution needs to be self-hosting. To build 
qt-designer with kde support, kdelibs needs to be installed, but you can't 
compile kdelibs without having qt installed.

The only way to fix this would be building qt and qt-designer from different 
source rpms, which wasn't possible for space reasons. This might be revisited 
for the next major release.




Note You need to log in before you can comment on or make changes to this bug.