Bug 534494 - (RHQ-1286) support auto-recalculation of dynagroups, configurable on the definition level
support auto-recalculation of dynagroups, configurable on the definition level
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
unspecified
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Joseph Marques
Jeff Weiss
http://jira.rhq-project.org/browse/RH...
: SubFeature
Depends On:
Blocks: RHQ-399
  Show dependency treegraph
 
Reported: 2008-12-19 00:27 EST by Joseph Marques
Modified: 2014-11-09 17:48 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph Marques 2008-12-19 00:27:00 EST
supported features

* set the recalculation interval in an integral number of minutes
* display the next time stamp for which the DynaGroups will be recalculated (on the view details and list page)
* if recalculation is enabled, it should work regardless of whether the DynaGroups has been manually calculated yet (to relinquish the user from having to manually calculate a dynagroup before this scheduling mechanism will work)
Comment 1 Joseph Marques 2008-12-19 00:43:00 EST
rev2474 - support auto-recalculation of dynagroups, configurable on the definition level with all features listed in the corresponding jira; 
Comment 2 Joseph Marques 2008-12-19 14:56:54 EST
rev2485 - switch the DynaGroup recalculation thread to be a quartz-initiated job instead of an EJB3 timer; 
Comment 3 Jeff Weiss 2009-01-06 12:58:48 EST
Did some basic functional testing, combined with viewing the monitor stats of the DynaGroup MBean, this all looks like it is working correctly.  rev2522
Comment 4 Red Hat Bugzilla 2009-11-10 15:29:46 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1286

Note You need to log in before you can comment on or make changes to this bug.