Bug 53452 - incomplete cfdisk removal
Summary: incomplete cfdisk removal
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: util-linux   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-09 15:39 UTC by Michael Redinger
Modified: 2007-04-18 16:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-16 17:08:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Redinger 2001-09-09 15:39:15 UTC
cfdisk seems to have been removed. However, this removal is still incomplete. There are still things in the spec file dealing with it (eg. moving it from /sbin/ /usr/sbin/) and the README.cfdisk file in /usr/share/doc/util-linux-xxx/ ist still there.
(Originally I planned to send the following to the testers-list, but
I don't think it's too useful to duplecate it ...)

From testers-list:

On Sat, 8 Sep 2001, Chris Negus wrote:

> Is the cfdisk command no longer included in 7.2? It was a bit more intuitive
> to use than fdisk.



cfdisk was previousely in util-linux.

/usr/sbin/cfdisk
/usr/share/doc/util-linux-xxx/README.cfdisk
/usr/share/man/man8/cfdisk.8.gz

cfdisk and the cfdisk man page are gone, README.cfdisk is still there
in the 2.11f-9 package.

In the SRPM, cfdisk.c and cfdisk.8 are still available in fdisk/ .

The spec file still contains stuff dealing with sfdisk, eg.:
# This has dependencies on stuff in /usr
%ifnarch sparc sparc64 sparcv9
mv ${RPM_BUILD_ROOT}/sbin/cfdisk ${RPM_BUILD_ROOT}/usr/sbin
%endif

However, cfdisk and cfdisk.8 are commented out:
#%{_sbindir}/cfdisk
#%{_mandir}/man8/cfdisk.8*

Finally, there's a nicht changelog entry:
* Sun Aug 26 2001 Elliot Lee <sopwith@redhat.com> 2.11f-9
- Don't include cfdisk, since it appears to be an even bigger pile of junk than fdisk? :)


It's obviousely a bug. If cfdisk is to be removed, do also remove the
README file and clean up the specs file ...

Comment 1 Elliot Lee 2002-01-04 18:34:29 UTC
ok ok, I'll fix the nits :)


Note You need to log in before you can comment on or make changes to this bug.