This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 534520 - (RHQ-1309) group definitions should support filtering from unset plugin/resource config props
group definitions should support filtering from unset plugin/resource config ...
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
unspecified
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Joseph Marques
Jeff Weiss
http://jira.rhq-project.org/browse/RH...
: SubFeature
Depends On:
Blocks: RHQ-399
  Show dependency treegraph
 
Reported: 2008-12-25 01:58 EST by Joseph Marques
Modified: 2014-11-09 17:48 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph Marques 2008-12-25 01:58:00 EST
today, it's impossible to find the unsecured JBossAS servers.  if groups could be filtered by unset/null properties, then the user could do something like:

empty resource.pluginConfiguration[principal]
resource.type.plugin = JBossAS
resource.type.name = JBossAS Server

since 'empty' is a type of reference comparison (as opposed to value comparison), might as well support the 'not empty' construct at the same time.  thus, the 3 supported major syntax variants would then be:

"condition = value"
"groupBy condition"
"(not) empty condition" // 'not' is optional
Comment 1 Joseph Marques 2008-12-25 01:59:53 EST
rev2539 - support filtering on unset/null plugin/resource configuration properties; 
in fact, this commit supports the general nullabllity of any condition that dynagroups supports; 
Comment 2 Jeff Weiss 2009-01-07 15:42:59 EST
Can now filter on unset values.  rev2561
Comment 3 Red Hat Bugzilla 2009-11-10 15:30:13 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1309

Note You need to log in before you can comment on or make changes to this bug.