Bug 53454 - XFree86 does not open windows in display 1
XFree86 does not open windows in display 1
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-09 12:22 EDT by Need Real Name
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-26 10:48:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-09-09 12:22:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
After starting X in display 0(which works as normal) an attempt opening a 
new X in display 1 with e.g. 'startx -- -depth 16 :1' Gives a grey screen 
in display 1 (<alt><ctrl><F8>) and all the windows in display 0. This 
worked prior to RH 7.0

Version-Release number of selected component (if applicable):
4.0.?

How reproducible:
Always

Steps to Reproduce:
1.Get a graphics display
2.Log into tty2
3.type: 'startx :1'
	

Actual Results:  Display 1 is grey
Display 0 get extra set of ikons, bars and windows 

Expected Results:  Display 1 should look like display 0

Additional info:

Tested in RH 7.0 and 7.1 in 2 different systems
Comment 1 Mike A. Harris 2001-09-23 06:22:57 EDT
startx :1  will not work.  You need to use:

startx -- :1

The "--" separated client args from server args.

Does that work for you?
Comment 2 Pel G. Larsson 2001-09-25 09:53:30 EDT
That solves the problem, but isn't it still a bug to place all windows and icons
in display 0 when you forget it?

Comment 3 Mike A. Harris 2001-09-25 17:03:29 EDT
Naw, 'man startx'

All arguments preceding "--" are client arguments, all arguments after
"--" are server arguments.  The display is a server argument, putting
it before "--" is invalid.
Comment 4 Pel G. Larsson 2001-09-26 10:48:02 EDT
The problem came up when I could not use -bpp anymore. In X4 it should be
-depth, but I can't make it work.

I guess as I stated the problem, it is not a bug
Comment 5 Mike A. Harris 2001-10-16 04:51:03 EDT
Ok, I'm closing this now, as it appears the problem you were having
was just simple misunderstanding of commandline options to startx.

Just to confirm multiple servers can start ok, I have just done the
following:

1) Using Radeon 64DDR, in runlevel 3
2) login as user mharris, run startx
3) login on another TTY as user mharris, run 'startx -- :1'
4) login on another TTY as user mharris, run 'startx -- :2'

I now have 3 separate X server's running and can VT switch between them,
all running the KDE desktop as user mharris.

Note You need to log in before you can comment on or make changes to this bug.