Bug 534563 - (RHQ-1348) can't pivot on resource.availability expression
can't pivot on resource.availability expression
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Core Server (Show other bugs)
1.2
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Joseph Marques
Jeff Weiss
http://jira.rhq-project.org/browse/RH...
: SubBug
Depends On:
Blocks: RHQ-399
  Show dependency treegraph
 
Reported: 2009-01-13 06:03 EST by Joseph Marques
Modified: 2014-11-09 17:48 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph Marques 2009-01-13 06:03:00 EST
if you try "groupby resource.availability" it will throw an exception and display an error message in the UI.  this should be supported.
Comment 1 Joseph Marques 2009-01-13 06:19:06 EST
rev2604 - support pivoting on resource.availability expression

to test:
* create a new group definition
* edit the expression set and enter "groupby resource.availability"
* click save // this should succeed, previously it failed
* then, calculate the groups

expected results: 
* one group for UP resources (assuming any exist in inventory)
* one group for DOWN  resources (assuming any exist in inventory)
* one group for UNKNOWN resources (assuming any exist in inventory [this can happen when a resource as been imported into the inventory, but an availability report hasn't been sent up to the server])
Comment 2 Jeff Weiss 2009-01-19 10:52:29 EST
I get 2 groups (because I don't have any with UNKNOWN avail).  rev2626 windows/oracle
Comment 3 Red Hat Bugzilla 2009-11-10 15:31:05 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1348

Note You need to log in before you can comment on or make changes to this bug.