This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 534579 - (RHQ-1362) nav should update when new resources are added to inventory
nav should update when new resources are added to inventory
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
1.2
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Greg Hinkle
Jeff Weiss
http://jira.rhq-project.org/browse/RH...
: SubBug
Depends On:
Blocks: RHQ-1267
  Show dependency treegraph
 
Reported: 2009-01-15 14:03 EST by Charles Crouch
Modified: 2015-02-01 18:24 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Charles Crouch 2009-01-15 14:03:00 EST

    
Comment 1 Joseph Marques 2009-01-15 14:56:08 EST
logging out and logging back in should fix this.  the tree component is placed in the session for performance reasons (it's expensive to gather the data needed for the tree).

perhaps we need a way of detecting that the inventory has changed and so to force the tree to recreate itself.  generally (read: hopefully) this won't be need all too often, and i would consider this a corner case, but it would be nice to eliminate session oddities like this.  since we already know when the inventory changes (specific methods on ResourceManagerBean are called), we can thus determine when the hierarchy under some platform has changed.  if we compare that time to the time when the tree nav was generated, that should be a fairly efficient mechanism that will allow us to cache the tree data/contents, but still know when that cache is stale and needs to be regenerated.
Comment 2 Charles Crouch 2009-01-16 12:02:51 EST
I don't consider new resources being added to the inventory and the user wanting to see them in the nav as a corner case.
People got annoyed with Embedded when the nav and tab views got out of sync, as is happening here.
There were various strategies we employed in embedded to resolve this, none completely satisfactory right now. Speak to Ian or myself if you want more details
Comment 3 Joseph Marques 2009-01-28 19:43:40 EST
charles, add whatever background info you can to this case
Comment 4 Joseph Marques 2009-02-09 11:13:28 EST
rev2966 - ghinkle moved tree to request scope, which should eliminate this issue.  
Comment 5 Jeff Weiss 2009-02-09 11:47:52 EST
Test this too - log in, view a platform inv tab, then view a 2nd platform.  The problem is the left nav still shows the 1st platform.

<joseph> jweiss: i'm thinking that the first time you log in it caches the tree in the session.  then you go to another platform, but the first platform is still in session.  you'll see this if you test against multi-platform inventories.  this should be fixed in the new cut to QA since the tree is stored in reqeust scope
<jweiss> joseph: ok thanks
 joseph: ghinkle: yeah that's it - the first tree i look at after logging in is the one it stays with until i log out - i'll comment on that same jira
Comment 6 Jeff Weiss 2009-03-26 14:05:46 EDT
The left nav now updates properly when
1) you add a resource in another session
2) when you navigate from one platform to another

rev3509
Comment 7 Red Hat Bugzilla 2009-11-10 15:31:21 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1362
This bug is duplicated by RHQ-1509

Note You need to log in before you can comment on or make changes to this bug.