Bug 534588 - (RHQ-1370) the agents need to get updated metric schedules properly
the agents need to get updated metric schedules properly
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Agent (Show other bugs)
unspecified
All All
high Severity medium (vote)
: ---
: ---
Assigned To: John Mazzitelli
Jeff Weiss
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-16 12:10 EST by John Mazzitelli
Modified: 2014-11-09 17:48 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2009-01-16 12:10:00 EST
The agents used to get their schedules updated during plugin deployment at server-start up time. We took that out (see associated JIRAs).  We need to provide a better way to update the schedules on the agents.
Comment 1 John Mazzitelli 2009-01-16 17:33:22 EST
discussions with ian, greg, jay resulted in the following:

we will modify the MTime of all resources that got new schedules added or got old scheduled removed due to new plugins getting deployed that added/removed metric definitions.

This change in mtime tells the agent that the resource needs to be synced. The agent code will remain the same - it will perform the sync code at the appropriate times.
Comment 2 Jeff Weiss 2009-02-04 14:00:01 EST
<mazz> jweiss: well, that was more internals, but, if you change a collection interval while an agent is down and restart the agent, make sure the new agent gets the new schedule properly

Tested as specified above.  rev2898
Comment 3 Red Hat Bugzilla 2009-11-10 15:31:31 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1370
This bug is related to RHQ-916
This bug is related to RHQ-1326

Note You need to log in before you can comment on or make changes to this bug.