Bug 5346 - problems with /cdrom exports
problems with /cdrom exports
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Depends On:
  Show dependency treegraph
Reported: 1999-09-24 07:02 EDT by srwalton
Modified: 2007-04-18 12:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-04-14 13:49:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description srwalton 1999-09-24 07:02:03 EDT
On RedHat 5.2, I had set up a system with the CD-ROM mounted
as /cdrom, 'user' mount privileges enabled, and /cdrom NFS
exported to an HP-UX 10.20 system.  Worked fine.  At RedHat
6.0, this no longer works.  Specifically:

1.  The HP-UX system cannot see the contents of the CD, even
though both the RedHat and HP sides report a successful
mount.  In particular, "ls /net/redhatbox/cdrom" on the HP
returns no output (where /net/redhatbox/cdrom is the NFS
mount point on the NFS client).  No errors appear on the
console or in any logs on either system.

2.  After a successful umount of the CD from the NFS client,
the RedHat system will not allow an unmount of the physical
CD unless NFS is stopped first;  '/cdrom:  device busy' is
the error returned otherwise.  This is the case when the
only NFS mount is from a non-HP-UX system as well.

I can export any other file system from RedHat to the HP-UX
box without trouble.  I have tried knfsd-1.4.7 from the
Rawhide distribution but there was no change.  I have tried
/sbin/rpcdebug but it complains that /proc/net/rpc/debug
doesn't exist.
Comment 1 atris 2000-02-08 09:33:59 EST
I also see such things on my RedHat 6.1.
When I mount _any_ filesystem, export them into NFS,
mount exported NFS shares, succesfully use them,
successfully unmount NFS shares, then I try to unmount
filesystem, ang got 'device busy'. After stopping and starting
NFS daemon I was able to unmount my filesystems. Simple restarting
NFS daemon does not have effect. I must stop and start nfsd again.
Comment 2 Cristian Gafton 2000-08-08 22:35:50 EDT
assigned to johnsonm
Comment 3 Stephen John Smoogen 2003-01-24 13:27:15 EST
Is this problem still occuring in Red Hat Linux 7.3/8.0? I could not duplicate
the exact problem, but may not be following the same steps as yours. 
Comment 4 Jay Turner 2003-04-14 13:49:17 EDT
Closing this out as result of bit-rot.

Note You need to log in before you can comment on or make changes to this bug.