Bug 53462 - clock wrong after suspend
clock wrong after suspend
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: apmd (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-09 17:44 EDT by Scott Otterson
Modified: 2014-03-16 22:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-02 17:47:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Otterson 2001-09-09 17:44:57 EDT
After returning from a system sleep on my laptop, the system time is
incorrect.  The problem occurred after I ran the program to upgrade RH6.2
to 7.1.  In 6.2, the clock was correct after suspend
Comment 1 Bernhard Rosenkraenzer 2001-09-11 05:27:59 EDT
Is the UTC={true,false} setting in /etc/sysconfig/clock correct?

Comment 2 Scott Otterson 2001-09-11 10:54:01 EDT
It's set to false.   But isn't true also a correct answer?
Comment 3 Scott Otterson 2001-09-11 11:45:20 EDT
I looked into this a bit more:  UTC is set to false. This seems to be correct,
because hwclock gives this answer: 

/sbin/hwclock  
Tue 11 Sep 2001 08:40:40 AM PDT  0.348267 seconds

In any case, the problem does not seem to be the hardware clock.  If I suspend
and then unsuspend, and then look and the hardware clock again, it is still
correct.  However, the date command shows that the system time is wrong.  For
example:

date -s 08:40
Tue Sep 11 08:40:00 PDT 2001

/sbin/hwclock  --systohc

/sbin/hwclock  
Tue 11 Sep 2001 08:40:40 AM PDT  0.348267 seconds

<suspend>
<unsuspend>

/sbin/hwclock  
Tue 11 Sep 2001 08:41:56 AM PDT  0.617520 seconds

date
Tue Sep 11 01:42:02 PDT 2001

Do you need me to run any other tests?
Comment 4 Bill Nottingham 2005-02-02 17:47:18 EST
Closing out bugs on older unsupported releases. Apologies for any lack
of response. Please reopen if it persists on current releases such as
Fedora Core 3.

Note You need to log in before you can comment on or make changes to this bug.