This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 534674 - (RHQ-1448) Add schedule id index to raw tables
Add schedule id index to raw tables
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Database (Show other bugs)
unspecified
All All
high Severity medium (vote)
: ---
: ---
Assigned To: Joseph Marques
http://jira.rhq-project.org/browse/RH...
: SubTask
Depends On:
Blocks: RHQ-1002
  Show dependency treegraph
 
Reported: 2009-01-30 17:47 EST by Charles Crouch
Modified: 2015-02-01 18:25 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Charles Crouch 2009-01-30 17:47:00 EST

    
Comment 1 Charles Crouch 2009-02-06 16:03:22 EST
r2946 update dbsetup
r2947 update dbupgrade
Comment 2 Heiko W. Rupp 2009-02-06 16:11:44 EST
Did you try to change the columns in the existing index to see if this makes a change?
Do you have good timing values of the old state, as two indexes also mean double work for the database to update the 2nd index too. And it uses more tablespace.
Comment 3 Charles Crouch 2009-02-10 09:46:30 EST
Initial one-off test: loading the metric tab for a 450member group (5charts)took a bit over 2mins
Comment 4 Charles Crouch 2009-02-23 18:32:31 EST
Changes have been applied, not the final answer, but looks like an improvement.
Comment 5 John Mazzitelli 2009-08-10 13:27:45 EDT
question as to why we created a new index when we already had a scheduleId/timestamp index.

Oracle is saying add an index on timestamp.

need to re-investigate this based on new performance numbers
Comment 6 Joseph Marques 2009-08-25 13:11:01 EDT
rev4989 - remove schedule_id index on raw tables; 
add time_stamp index on raw tables; 
Comment 7 Charles Crouch 2009-09-01 11:00:08 EDT
Assigning to Joseph who is working on migrating our perf branch fixes to /trunk
Comment 8 Joseph Marques 2009-09-03 03:53:45 EDT
rev5087 - remove schedule_id index on raw tables, which is redundant with the composite index already on those respective tables; 
Comment 9 Red Hat Bugzilla 2009-11-10 15:33:12 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1448

Note You need to log in before you can comment on or make changes to this bug.