This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 534685 - (RHQ-1458) Left tree nav not fully distinguishing on resource type
Left tree nav not fully distinguishing on resource type
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
1.2
All All
high Severity medium (vote)
: ---
: ---
Assigned To: Greg Hinkle
Jeff Weiss
http://jira.rhq-project.org/browse/RH...
: SubBug
Depends On:
Blocks: RHQ-1267
  Show dependency treegraph
 
Reported: 2009-02-02 11:39 EST by Jay Shaughnessy
Modified: 2014-11-09 17:48 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Vista/FF2
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
two-autogroups.jpg (40.90 KB, image/jpeg)
2009-02-02 11:40 EST, Jay Shaughnessy
no flags Details
Screenshot-JON - Tomcat Server 'witte.usersys.redhat.com Apache Tomcat 6.0.18.0 (8080)' - Inventory Data - Mozilla Firefox.png (204.61 KB, image/png)
2009-02-23 11:43 EST, Jeff Weiss
no flags Details

  None (edit)
Description Jay Shaughnessy 2009-02-02 11:39:00 EST
Resources with the same resource type name, but different plugins, are showing up too often. For example, I'm working on the standalone Tomcat plugin.  Currently both the Tomcat plugin and JBossAS plugin can have children of type "Web Application (WAR)".  These resource show up under my standalone Apache Tomcat Server sub-tree and JBossAS Server sub-tree.  They are auto-grouped separately, but each parent has the two auto-groups.

See attached screen capture.
Comment 1 Jay Shaughnessy 2009-02-02 14:17:42 EST
Not sure, this may have to do with subcategories of the same name.
Comment 2 Greg Hinkle 2009-02-04 00:34:08 EST
Jay, this is working as expected. They need to be grouped separately since they are actually distinct resource types. If they were grouped together the autogroup UI would fail on aspects that are different between the resource types that happen to have the same name. In reality, I can't think of a reason this would happen in valid plugins.
Comment 3 Greg Hinkle 2009-02-05 16:58:30 EST
misunderstood the issue
Comment 4 Jeff Weiss 2009-02-23 11:42:44 EST
The resources are now shown separately, see screenshot.  rev3078, linux/postgres
Comment 5 Red Hat Bugzilla 2009-11-10 15:33:26 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1458
Imported an attachment (id=368551)
Imported an attachment (id=368552)

Note You need to log in before you can comment on or make changes to this bug.