This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 534698 - (RHQ-146) server properties not required for server startup, or that don't require a restart when modified, should be configured via the Administration>Server Configuration page, rather than rhq-server.properties
server properties not required for server startup, or that don't require a re...
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
0.1
All All
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
http://jira.rhq-project.org/browse/RH...
: FutureFeature, Improvement
Depends On: RHQ-644
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-17 17:53 EDT by Ian Springer
Modified: 2014-05-02 16:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-02 16:57:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ian Springer 2008-03-17 17:53:00 EDT
Examples of properties that should be moved:

# Email
rhq.server.email.smtp-host=localhost
rhq.server.email.smtp-port=25
rhq.server.email.from-address=rhqadmin@localhost

# Operations/controls timeout
# Defines the default timeout for all operations (specified in seconds)
rhq.server.operation-timeout=600
Comment 1 John Mazzitelli 2008-03-17 22:22:39 EDT
This may or may not be true and it depends on the property.

Keep in mind the future requirement of being able to cluster the server.  There may be cases where certain properties must be set on a per-server basis (i.e. rhq-server.properties).  Putting things in the database in RHQ_SYSTEM_CONFIG means ALL servers in the cluster will have the identical settings.  This may not be want you want (e.g. the email SMTP host/port may be different depending on where in the network particular RHQ Server nodes are deployed).


Comment 2 Greg Hinkle 2008-05-21 23:42:14 EDT
Moving to future
Comment 3 Joseph Marques 2008-07-21 00:45:41 EDT
will use this jira to keep track of what could possible be reset via the server admin page in an HA environment.
Comment 4 Red Hat Bugzilla 2009-11-10 15:33:40 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-146
Comment 5 Corey Welton 2010-08-18 11:27:33 EDT
joseph, current thoughts?
Comment 6 Joseph Marques 2010-08-18 13:43:10 EDT
I think ALL entries in the rhq-server.properties file should be editable through the UI.  However, instead of editing them one at a time, we should use the group configuration component to render the UI.  In this way, the administrator can easily choose which properties should have the same value across the server cluster, and which should have different values - the group config component allows both of these use cases easily.

The only question we have is whether we build this functionality into the core UI, or develop it as the configuration subsystem implementation for the RHQ Server resource type.  The former has the benefit of being configurable regardless of whether the RHQ Server(s) have been discovered/imported, and can also be made available through the admin pages.  The latter might/should be an easier solution implementation-wise, because it fits into our existing plugin model.

Note You need to log in before you can comment on or make changes to this bug.