Bug 53471 - [RFE] up2date should allow download of pkgs/src package w/o solving deps
Summary: [RFE] up2date should allow download of pkgs/src package w/o solving deps
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords: FutureFeature
: 84546 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-10 03:38 UTC by Brian Ryner
Modified: 2015-01-07 23:51 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-27 00:14:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian Ryner 2001-09-10 03:38:40 UTC
Description of Problem:

If up2date is configured to not install packages after downloading them,
then an unresolved dependency should not be a fatal error - the packages
should still be downloaded.

Version-Release number of selected component (if applicable):

2.6.0-7.x.37

How Reproducible:  always


Steps to Reproduce:
1. Install a package that depends on a particular version of a
RedHat-supplied package.
2. Run up2date-config, and set it to only download packages, not install them.
3. Run up2date and select to update the package that the external package
depends on.

Actual Results:

An unresolved dependencies dialog appears, and it is impossible to continue
with the download.

Expected Results:

A warning should be shown, but the user should have the option to download
the package anyway.

Additional Information:

Comment 1 Adrian Likins 2001-10-24 22:13:28 UTC
For the time being, this is "working as designed". Basically, the intention
is that up2date only installs/fetches package sets if they can be installed
correctly. Downloading a partial set of packages cant provide that guarantee.

It could be argued that up2date should let you download only any 
given package regardless of what dep errors it might cause. We'll
take a look at maybe changing that spec and possiblly adding the
ability to support that mode of operations

Comment 2 Adrian Likins 2002-03-26 23:31:12 UTC
A couple people have asked for the ability to directly download
a package or packages even if it cant be installed properly, so
marking this as an request for enhancement.

Comment 3 Adrian Likins 2003-06-24 23:41:36 UTC
added in 3.1.35

Comment 4 Adrian Likins 2003-07-28 20:58:26 UTC
*** Bug 84546 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.