Bug 534778 - (RHQ-1541) unchecking "unset" at the aggregate leaves drill-down properties read-only
unchecking "unset" at the aggregate leaves drill-down properties read-only
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Configuration (Show other bugs)
1.2
All All
high Severity medium (vote)
: ---
: ---
Assigned To: Ian Springer
Jeff Weiss
http://jira.rhq-project.org/browse/RH...
: SubBug
Depends On:
Blocks: RHQ-1386
  Show dependency treegraph
 
Reported: 2009-02-11 15:09 EST by Joseph Marques
Modified: 2014-11-09 17:48 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph Marques 2009-02-11 15:09:00 EST
steps to reproduce:

* edit from group config
* find some property that is currently "unset" at the aggregate
* uncheck that, notice that the value space becomes editable at the aggregate
* click the corresponding members button

expected results:

* all individual properties are editable

actual results:

* all individual properties are still read-only, as if the drill-down component wasn't notified that "unset" was unchecked at the aggregate level
Comment 1 Ian Springer 2009-02-12 16:06:00 EST
This one's going to be fairly complicated. Coordinating the unset controls between the main page and the modal panel is complicated because of the JavaScript that is rendered to initialize the unset checkboxes.
Comment 2 Ian Springer 2009-02-27 17:39:02 EST
I must have fixed this at some point in the past week. I'm not sure exactly which revision(s) fixed it, but it is working as of r3143.
Comment 3 Jeff Weiss 2009-03-11 11:44:42 EDT
Fixed, rev3351
Comment 4 Red Hat Bugzilla 2009-11-10 15:35:14 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1541

Note You need to log in before you can comment on or make changes to this bug.