Bug 534841 - (RHQ-1599) add descriptions to all metrics
add descriptions to all metrics
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
unspecified
All All
low Severity medium (vote)
: ---
: ---
Assigned To: Joseph Marques
Jeff Weiss
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-18 10:16 EST by John Mazzitelli
Modified: 2014-11-09 17:48 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2009-02-18 10:16:00 EST
I noticed that some metrics in our plugins do not have descriptions. I noticed this because I hovered over one (Platform's Free Memory) and the tool tip told me "there is no description for this metric". We should go through all our plugins and add descriptions so users won't see that useless popup on our own plugins.
Comment 1 John Mazzitelli 2009-02-18 10:17:01 EST
this is easy to do and should be done for 1.2
Comment 2 Heiko W. Rupp 2009-03-05 08:11:20 EST
An alternative approach would be to just use the display name as description when no description is given.
Advantage is that this also works for plugins we don't have source for.
This can be easily done in the Metric Metadata  parser:

Index: rhq/modules/core/client-api/src/main/java/org/rhq/core/clientapi/agent/me
tadata/MetricsMetadataParser.java
===================================================================
--- rhq/modules/core/client-api/src/main/java/org/rhq/core/clientapi/agent/metad
ata/MetricsMetadataParser.java  (revision 3292)
+++ rhq/modules/core/client-api/src/main/java/org/rhq/core/clientapi/agent/metad
ata/MetricsMetadataParser.java  Thu Mar 05 14:08:26 CET 2009
@@ -111,12 +111,16 @@
             dataType), dataType, NumericType.valueOf(metricDescriptor.getMeasur
ementType().toUpperCase()),
             metricDescriptor.isDefaultOn(), collectionInterval, displayType);
 
-        definition.setDescription(metricDescriptor.getDescription());
         if (metricDescriptor.getDisplayName() != null) {
             definition.setDisplayName(metricDescriptor.getDisplayName());
         } else {
             definition.setDisplayName(StringUtils.deCamelCase(definition.getNam
e()));
         }
+        if (metricDescriptor.getDescription() != null) {
+            definition.setDescription(metricDescriptor.getDescription());
+        } else {
+            definition.setDescription(definition.getDisplayName());
+        }
 
         definition.setDestinationType(metricDescriptor.getDestinationType());
Comment 3 Heiko W. Rupp 2009-03-05 08:24:15 EST
The patch from the last comment has been committed in rev3295
Comment 4 Joseph Marques 2009-03-05 11:16:06 EST
granted, adding the name to the description field would give it some value, but since the name will always be displayed alongside the description it would only add redundancy for the sake of getting rid of empty table cells.  we should spend the necessary time to fill in all of the missing descriptions properly.
Comment 5 Heiko W. Rupp 2009-03-05 11:28:47 EST
Ok.
Comment 6 Joseph Marques 2009-03-21 00:40:13 EDT
rev3473 - add descriptions to all metrics missing them;
Comment 7 Jeff Weiss 2009-03-31 11:04:02 EDT
I'm not going to be able to check every single metric, but I checked the one specifically mentioned in this jira (plat free mem) and will keep an eye out for other missing descriptions, and file issues separately.
Comment 8 Red Hat Bugzilla 2009-11-10 15:36:27 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1599

Note You need to log in before you can comment on or make changes to this bug.