Bug 53491 - RPM update breaks sendmail
RPM update breaks sendmail
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: sendmail (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Florian La Roche
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-10 10:51 EDT by Timothy Burt
Modified: 2007-04-18 12:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-18 13:08:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Timothy Burt 2001-09-10 10:51:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
Sep 9th RPM updates:
sendmail-8.11.6-1.7.0.i386.rpm
sendmail-cf-8.11.6-1.7.0.i386.rpm
sendmail-doc-8.11.6-1.7.0.i386.rpm
When installed, these RPM's will cripple sendmail.
Sendmail refuses to accept connections on port 25
A quick diff of the new sendmail.cf file indicates that naming structure 
for db files may have changed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Update sendmail with RPMs
2.Try to open port 25
3.
	

Actual Results:  Access Denied

Additional info:
Comment 1 Fran Boon 2001-09-11 06:41:10 EDT
I just got the same problem.
I'm using a separate sendmail.cf
Updating from sendmail-8.11.0-8 to sendmail-8.11.6-1.7.0 on i386 gives the 
following errors in the maillog:

Sep 11 10:04:46 mail sendmail[11088]: f8BA4kD11088: tcpwrappers (ch5as09-73-244-
208.cw-visp.com, 212.137.244.
208) rejection
Sep 11 10:04:46 mail sendmail[11088]: NOQUEUE: ch5as09-73-244-208.cw-visp.com 
[212.137.244.208] did not issue
 MAIL/EXPN/VRFY/ETRN during connection to Daemon0
Sep 11 10:07:04 mail sendmail[11094]: f8BA73D11094: tcpwrappers 
(ex3lujmoims01.cec.eu.int, 158.169.9.54) reje
ction
Sep 11 10:07:04 mail sendmail[11094]: NOQUEUE: ex3lujmoims01.cec.eu.int 
[158.169.9.54] did not issue MAIL/EXP
N/VRFY/ETRN during connection to Daemon0
Sep 11 10:12:57 mail sendmail[11160]: f8BACpD11160: tcpwrappers 
(corp1.cbn.net.id, 202.158.3.24) rejection
Sep 11 10:13:08 mail sendmail[11160]: NOQUEUE: corp1.cbn.net.id [202.158.3.24] 
did not issue MAIL/EXPN/VRFY/E
TRN during connection to Daemon0
Comment 2 Need Real Name 2001-09-12 12:26:51 EDT
I'm having the same problem. Sendmail worked fine till the RPM. Now what????? 
Does Red Hat provide FREE support for what they break?
Comment 3 Fran Boon 2001-09-14 11:48:49 EDT
FIX:
vi /etc/hosts.allow
Sendmail: ALL

ChangeLog mentions this vaguely:
* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
- tcp-wrapper support wasn't enabled correctly #21642
* Fri May 19 2000 Florian La Roche <Florian.LaRoche@redhat.com>
- enable tcp_wrapper support

This should have been clearly documented in the update notice...
Comment 4 Terry Griffin 2001-09-17 12:14:41 EDT
I can't get the /etc/hosts.allow fix to work. I even put in an "ALL : ALL" temporarily as a test, and still the connection was refused
by sendmail. Any other ideas?

Come on Red Hat. Where's the fix? You really botched this one, taking out all of our mail servers like this.
Comment 5 Need Real Name 2001-09-18 13:04:57 EDT
This was sent to me via Red Hat so I copied and pasted the fix. Hope that isn't 
a problem

JE

Ok, most of us have probably seen this, and if you haven't you can have it
to look forward too. Customers will upgrade sendmail because of the errata
and alot of folks will now have a broken sendmail.

Here is what is going on:

IF they have never changed their /etc/sendmail.cf file and do the upgrade,
that file will be updated to the "stock" sendmail.cf. This stock version
DOES NOT allow any incomming connections. This is just like we have delt
with since Red Hat Linux 7.1 was released. So even if they have Red Hat
6.1 and upgrade, they now have the same issues to deal with that 7.1 had.

So how do you fix it.....

find this line in /etc/mail/sendmail.mc

DAEMON_OPTIONS(`Port=smtp,Addr=127.0.0.1, Name=MTA')

and put dnl in front of it.

dnl DAEMON_OPTIONS(`Port=smtp,Addr=127.0.0.1, Name=MTA')

save the file and issue this command:

m4 /etc/mail/sendmail.mc > /etc/sendmail.cf

then issue

service sendmail restart

If incomming mail still does not work, then you need to check one other
place. This new version of sendmail has tcpwrappers compiled in. So even
though someone using tcp wrappers before never had a problem with
sendmail, if they upgrade and havent accounted for it, it will break
sendmail and it will not work.

what do you do......

check /etc/hosts.deny

If there is anything in it, that does not start with "#", especially if it
has a line in it like this:

All:    ALL

Sendmail will not work. They will have to add an entry to /etc/hosts.allow
to permit outside connections to sendmail. I haven't tested this but this
"should" work:

/etc/hosts.allow

sendmail:   ALL


This should fix any problems you run across, that are caused from the
upgrade.
Comment 6 Need Real Name 2001-09-18 13:08:52 EDT
One thing I had to do that is different to restart sendmail is:
/etc/rc.d/init.d/sendmail restart
Comment 7 Florian La Roche 2001-12-07 15:52:51 EST
There is a updated rpm available via ftp/Red Hat Network that should fix
the problem that the default configuration only enabled network access
for localhost instead of for all network devices.

Thanks,

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.