Bug 534941 - (RHQ-1689) cannot expand a selected category
cannot expand a selected category
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
unspecified
All All
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
http://jira.rhq-project.org/browse/RH...
:
Depends On:
Blocks: rhq4
  Show dependency treegraph
 
Reported: 2009-02-28 14:32 EST by John Mazzitelli
Modified: 2011-02-11 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-11 17:10:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot-1.jpg (6.77 KB, image/jpeg)
2009-02-28 14:34 EST, John Mazzitelli
no flags Details

  None (edit)
Description John Mazzitelli 2009-02-28 14:32:00 EST
to replicate

1) create a compatible group of type with categories (I used JBossAS Server)
2) add 2 or more resources to the group
3) navigate to the group view
4) select a category in the left-nav (I selected "Applications")
5) now try to expand that category you selected

You will find that you cannot expand it (nor can you expand any other category, which I think is to be expected because you can't expand tree nodes that our outside of the ancestry of the resource that is selected - but I think you should be able to expand the selected category).

I will attach a screenshot. 
Comment 1 John Mazzitelli 2009-02-28 14:34:17 EST
in the attached screenshot, you will see I have selected the JBossAS Server category called "Applications" in my compatible group that is called "My Application Group"

When I try to click the expand arrow button, the UI does nothing. I would have expected that Applications group to expand and show me the individual tree nodes within it.

I do have children under Applications - two in fact. So I know there are nodes under there.

Workaround: click to select the root node "My Application Group". Then you can expand Applications node.
Comment 2 Red Hat Bugzilla 2009-11-10 15:38:21 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1689
Imported an attachment (id=368613)
Comment 3 John Mazzitelli 2011-02-11 17:10:18 EST
this was a jsf issue  - we impl this now in gwt

Note You need to log in before you can comment on or make changes to this bug.