Bug 53511 - fix /etc/rc.sysinit to handle all IDE harddisks
Summary: fix /etc/rc.sysinit to handle all IDE harddisks
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: roswell
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-10 17:45 UTC by Jim Wright
Modified: 2014-03-17 02:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-30 08:27:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix /etc/rc.sysinit (986 bytes, patch)
2001-09-10 17:50 UTC, Jim Wright
no flags Details | Diff

Description Jim Wright 2001-09-10 17:45:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.8-xfs i686)

Description of problem:
/etc/rc.sysinit has the code to tweak IDE hard drives using the information
found in /etc/sysconfig/harddisk*.  As distributed, it only affects the
first 8 drives.  Should be fixed to support all IDE drives which the kernel
supports.

I've had to patch this in previous releases as well.  Would be nice to get
fixed in the distribution.

Note that it is not too hard go beyond hdh if you only use master and no
slaves on the IDE controllers.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Add disk beyond hdh
2.  modify /etc/sysconfig/harddisks (or specific file)
3.  reboot and see disk settings not take effect
	

Additional info:

I will attach a patch.  Fix is trivial.  I've been using it on production
servers for several months.

Comment 1 Jim Wright 2001-09-10 17:50:06 UTC
Created attachment 31516 [details]
patch to fix /etc/rc.sysinit

Comment 2 Jim Wright 2001-09-10 17:51:12 UTC
Oh yeah, since there should never be a /proc/ide/s/media file, I omitted the
check
for the zeroth drive.

Comment 3 Jim Wright 2002-01-30 08:27:07 UTC
this seems like an easy one to knock off.  can it be included in the next
release?

Comment 4 Bill Nottingham 2002-04-15 02:33:03 UTC
The 's' is there so it sources /etc/sysconfig/harddisks by default... otherwise,
will be added in 6.64-1.

Comment 5 Jim Wright 2002-04-15 04:44:52 UTC
you are correct, iterating over "0" in the for loop is necessary to initialize
the HDFLAGS[0] variable for later use as the default value.

thanks for adding this to the script.


Note You need to log in before you can comment on or make changes to this bug.